Connecting to RDP session on server 2019

w_marquardt
w_marquardt used Ask the Experts™
on
I just installed a new version of server 2019 and have replaced the 2008 server that acted as the RDP server. I can connect to the 2019 server without any problem with the windows 7-10 remote desktop client. What I can't connect with is our terminal server clients that have been built with Linux (puppy) and rdesktop. They worked fine under 2008 but will not do anything (no error message or other info). I can remotely connect to any of the other servers in the building (the rest are all 2008 R2.)

I have added all of the domain users to the people who can connect list.  The restriction for Network Level authentication is turned off.

I haven't' worked with 2019 yet so I'm not coming up with any ideas of what the problem might be.

Can someone point me in the right direction for a solution?

BTW: I will not be able to get back to this until next week because they are shutting down at the end of the day until then for the holiday.

Thanks for the assist with this.

Regards,

Bill
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Distinguished Expert 2017

Commented:
try rdesktop -A

There has to be some error that potentially deals with Encryption and the untrusted Certificate the server present.

presumably you are either in the 120 eval period, or deployed an RDS ....

Author

Commented:
Arnold, I'll give that a try when I can get back onsite. I don't have any access remotely to the linux boxes and they are closed until next Monday.

Thanks for the heads up on this. It's pretty much what I was thinking but since we never had problems under 2008, I'm kind of surprised that it seems to be needed to be fixed at the workstation.

Author

Commented:
Sorry for the delay on this. To get things working I had to restore the original server configuration. I can't do the new upgrade until after the first of the year. I'll revisit this then.
Commented:
It looks like rdesktop doesn't play well with Server 2019. It is working under server 2016 with a few hiccups with the linux clients. I've created a new question for those issues.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial