Link to home
Create AccountLog in
Avatar of Mr.X
Mr.X

asked on

set jnlp extension to java web launcher

hi
got windows 10 computer
got a website which requires jnlp extension to open in java web launcher.

when I go to default application, - file extensions, for jnlp - it’s set to internet explorer, but does not give an option to change to java web launcher

it got only adobe reader/ IE/ Microsoft store. no option to select java web launcher .

any idea to set jnlp default to java web launcher ?!
[embed=file 1437521]
IMG_7389.jpg
Avatar of Peter Hutchison
Peter Hutchison
Flag of United Kingdom of Great Britain and Northern Ireland image

Opening JNLP is different from opening the plugin for IE. JNLP will use the Javaw.exe executable which is configured via Java Control Panel:
A few things to check:
a) Open Java Control panel (or javacpl.cpl program directly).
b) Click on Advanced tab.
c) Select 'Prompt user' for JNLP File/MIME Association.


f) Open Regedit
g) Expand HKEY_Classes_Root\jnlp\shell\open\command and check command is set to use jp2launcher.exe with -securejws option with %1 parameter.
Used to be javaws.exe to launch. Have you got that installed?
Avatar of Mr.X
Mr.X

ASKER

I had a jnlp file. so I just right click on always open with javaws application. and it worked since then
ASKER CERTIFIED SOLUTION
Avatar of Mr.X
Mr.X

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
I had a jnlp file. so I just right click on always open with javaws application. and it worked since then

Yes, that's good. Actually i've always preferred to use javaws from the command line since you get the most output
JNLP will use the Javaw.exe executable which is configured via Java Control Panel:
javaw is actually an 'invisible console' usually
I had a jnlp file. so I just right click on always open with javaws application. and it worked since then
So - you used the app i told you to use and it solved your problem