We help IT Professionals succeed at work.

Brand new edge router x slow bandwidth

I purchased a EdgeRouter X  so that I can take advantage a 200 MEG connection. When I plug directly into the cable modem I get about 175. When I plug the router in, I get about 10 mbps down and 13 up. This router is brand new, replacing and old Netgear ac1200.

I did upgrade to the latest firmware with no change.

ubnt@ubnt# show
 firewall {
     all-ping enable
     broadcast-ping disable
     ipv6-receive-redirects disable
     ipv6-src-route disable
     ip-src-route disable
     log-martians enable
     name WAN_IN {
         default-action drop
         description "WAN to internal"
         rule 10 {
             action accept
             description "Allow established/related"
             state {
                 established enable
                 related enable
             }
         }
         rule 20 {
             action drop
             description "Drop invalid state"
             state {
                 invalid enable
             }
         }
     }
     name WAN_LOCAL {
         default-action drop
         description "WAN to router"
         rule 10 {
             action accept
             description "Allow established/related"
             state {
                 established enable
                 related enable
             }
         }
         rule 20 {
             action drop
             description "Drop invalid state"
             state {
                 invalid enable
             }
         }
     }
     receive-redirects disable
     send-redirects enable
     source-validation disable
     syn-cookies enable
 }
 interfaces {
     ethernet eth0 {
         address DNS/28
         description Internet
         duplex auto
         firewall {
             in {
                 name WAN_IN
             }
             local {
                 name WAN_LOCAL
             }
         }
         speed auto
     }
     ethernet eth1 {
         description Local
         duplex auto
         speed auto
     }
     ethernet eth2 {
         description Local
         duplex auto
         speed auto
     }
     ethernet eth3 {
         description Local
         duplex auto
         speed auto
     }
     ethernet eth4 {
         description Local
         duplex auto
         speed auto
     }
     loopback lo {
     }
     switch switch0 {
         address 192.168.16.1/24
         description Local
         mtu 1500
         switch-port {
             interface eth1 {
             }
             interface eth2 {
             }
             interface eth3 {
             }
             interface eth4 {
             }
             vlan-aware disable
         }
     }
 }
 service {
     dhcp-server {
         disabled false
         hostfile-update disable
         shared-network-name LAN {
             authoritative enable
             subnet 192.168.16.0/24 {
                 default-router 192.168.16.1
                 dns-server 192.168.16.1
                 lease 86400
                 start 192.168.16.38 {
                     stop 192.168.168.243
                 }
             }
         }
         static-arp disable
         use-dnsmasq disable
     }
     dns {
         forwarding {
             cache-size 150
             listen-on switch0
         }
     }
     gui {
         http-port 80
         https-port 443
         older-ciphers enable
     }
     nat {
         rule 5010 {
             description "masquerade for WAN"
             outbound-interface eth0
             type masquerade
         }
     }
     ssh {
         port 22
         protocol-version v2
     }
 }
 system {
     gateway-address MYIPADDRESS
     host-name ubnt
     login {
         user ubnt {
             authentication {
                 encrypted-password pass
             }
             level admin
         }
     }
     name-server DNS1
     ntp {
         server 0.ubnt.pool.ntp.org {
         }
         server 1.ubnt.pool.ntp.org {
         }
         server 2.ubnt.pool.ntp.org {
         }
         server 3.ubnt.pool.ntp.org {
         }
     }
     offload {
         hwnat enable
     }
     syslog {
         global {
             facility all {
                 level notice
             }
             facility protocols {
                 level debug
             }
         }
     }
     time-zone UTC
 }
[edit]
Doesn't seem like anything is sucking it down.
Comment
Watch Question

Commented:
In some unique cases, ports on auto don't communicate properly. Can you first fix it to Gbit (if possible on BOTH sides)?

Author

Commented:
I set it to 100/full and same result.

Author

Commented:
Anything? I need to get this resolved.

Commented:
Try 1000/full (as that's probably the cable modem's setting as well)

Author

Commented:
It does not have a 1000... just says 100 full.

Author

Commented:
There is nothing special about this network. A cable mode, an edgerouter... thats its.. I unplugged everything else.

Commented:
Then back to auto.
But please check if you have a higher quality UTP cable lying around to connect the ER-X with the cable modem.In some cases, the connections don't like cross cables (while it should), so make sure a straight cable is used.

Author

Commented:
I just changed the cable and same result.

Author

Commented:
Wow..... now its working properly all of a sudden.... smh

Author

Commented:
Its up and down, I don't get 175 mbps consistently. Right now its 29... shouldn't a speedtest render about 175-210 consistent?
Commented:
Depends on a lot of factors, How is the device that's running speedtest connected? If WiFi, you already add another step that might interfere. Are you the only one using the internet at the time of running speedtest? If the cable modem has one more port, connect a fast device to it (server with SSD and also GB NIC). If you consistently connect to this device with file copies over 200Mbps, while the internet doesn't, it's purely an ISP issue.

If your neighbors with the same ISP/cable modem report the same problem, you usually don't have to test internally anymore, it's an ISP issue.

Author

Commented:
Turns out Cox had an issue with a node down the road.