Exchange 2016 and 2010 coexistence

billFmurray
billFmurray used Ask the Experts™
on
Hi,
We installed 2016 in an org with 2010 servers.  Before I did the NLB cutover, I wanted to make sure everything was working with hosts files.

Note--One thing I noticed was that autodiscover was not in the 2010 certificate.  New profiles could be created ok, though.
In 2010 there is an autodisover.contoso.com which points to ip x.x.x.10
and then all the other exchange urls: mail.contoso.com which also point to x.x.x.10

I set up the new server, configured the urls and certificates (exported old 2010 ones) on 2016.  ECP looks ok.  I was able to create a new mailbox.  OWA let's me log in to 2016 mailbox--as well as proxy back for 2010 mailbox.

When I configured a client (Outlook 2016 on win10) with a mailbox on the new server, I couldn't get it to work with hostfiles pointing to the new server.  I can't create a new profile.  It says server not online.

When I log into outlook as a 2010 user and do the test autoconfiguration for the 2016 user i get Autoconfiguration was unable to determine your settings.
The log for test email autoconfiguration say:
autodiscovered fauled (0x80004005) and further down (0x800c8204).  When I look them up they say to remove a hkcu\...outlook\autodiscover key which we don't have.
also see some httpstatus=401 and 302 and 400's (not sure what those mean)

I wanted to know what else I should do to test connectivity to the 2016 servers.  The firewall guy says there's no rules blocking the autodiscover ip's.    Could it be the cert?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
AmitIT Architect
Distinguished Expert 2017

Commented:
Did you updated the SCP configuration.

Author

Commented:
yes scp was set up actually
CEO Faru Bonon IT /Top Rated Freelancer on Upwork / Photographer
Awarded 2018
Distinguished Expert 2018
Commented:
Ping autodiscover.<domain.com>
It should aim or go to the newest exchange server (2016)

Then open a browser and go to
https://autodiscover.<domain.com>/autodiscover/autodiscover.xml

it should prompt username and password and then fail

Finally Take a computer with outlook, open outlook with ctrl+right click on outlook's icon beside the time.
disable guessmart and the other box, just leave autodiscover and post the log inside that box...

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial