How can I set up an FTP server?

DoctorK12008
DoctorK12008 used Ask the Experts™
on
I have  Canon EOS 7D with a WFT attached.   I need to set up an FTP server in Windows 10 Professional X64.   I have set up the site in IIS, but I cannot get the WFT to connect to the FTP server.   I get the error 45 or 41, cannot connect to the FTP server.   The WFT connects to the router, but is not able to get any further.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Distinguished Expert 2017

Commented:
You need to add the FTP component under iis.

Look at FileZilla server.
What other resources do you have?

Author

Commented:
I already added the site, but I need to know how to figure it.   I disabled the firewall, but that made no difference.
Distinguished Expert 2017

Commented:
Did you add the FTP portion, can you access the FTP server on the workstation

FTP localhost?

If you do not see FTP in the iis admin tool, this means you did not install the FTP, but just the web server.
Pkease post the image of the iis administrative tool.
If you only gave application pool and sites, this deals with web services.

Author

Commented:
FTP site created OK, but still cannot connect from the WFT to the FTP server.   I get error 41 or 45.FTP
Distinguished Expert 2017

Commented:
Are you allowing anonymous loggins?
Double check advanced firewall settings to make sure you are FTP allowed through the firewall.
Are you looking to create specific username to gave access to FTP?

Author

Commented:
I disabled both AVG and Malwarebytes, but that did not make any difference.   I am trying to connect a Canon camera 's WFT to the computer in order to download images are they are taken with the camera.   It seems the camera connects to the wireless router with no problem, but the FTP server in the computer blocks access to the folder on the computer.   I have set the folder up a shared by everyone for read/write.
Distinguished Expert 2017

Commented:
Can you access the FTP on the server?
Use an FTP client or open a command window directly on the server to avoid installing .additional products on the server
FTP localhost

On the server look at netstat -an | find /I "listen"

Do you have an instance listening on port 21
*:21
0.0.0.0:21?

Does the Windows firewall allow port 21 incoming access? Does it have a specified range?
Where are you testing the connection from?
Where was avg/malwarebytes setup? On the server on the workstation from which you are testing?

FTP is a two part protocol
21 port is the inbound connection to the server.
In a direct connection, after authentication, the server initiates the connection from port 20 back to the client.

In a case where the client is behind a firewall. They initiate a passive connection which alters the second part of the connection.
The server designates a random port from a range on which it will wait for the connection from the client.
The client has to determine it from the response to PASV
And then connect to the port.
In your case, this range has to be authorized to pass the Windows firewall for local access.

If you are connecting from the outside, the external firewall has to handle the two sections.

Author

Commented:
The FTP is set up on the computer that has the shared folder that I want to send the images to.   Windows firewall is controlled by the AVG.   Do I need to set up the AVG to allow the connection, even if it is disabled?
Distinguished Expert 2017

Commented:
Please answer the questions posed.
1) confirm the FTP service is working locally on the system where it is installed and then expand outwards until you fix the issue.
Yes, if you have the firewall component, you have to make sure it is permitted.

So far I understand what you want, I am unable to determine where your issue is

FTP server <=> Windows firewall or avg firewall <=> lan
Test from another computer if you have it to confirm you can access the FTP server.

On the camera, do you use anonymous access or a specific user login into FTP.
For anonymous you need to make sure you allow writes into the folder, commonly use an upload folder with write only rights.

Author

Commented:
Sorry, I do not have enough technical knowledge to follow your instructions.   How do I "1) confirm the FTP service is working locally on the system where it is installed and then expand outwards until you fix the issue."?

How do I "Test from another computer if you have it to confirm you can access the FTP server."?

I use anonymous access on the camera.

Sorry again for my lack of technical knowledge and thank you for your patience.
Distinguished Expert 2017

Commented:
open a command windows
hit the windows key and type cmd.exe
in the window type
ftp localhost

once you press enter, do you get a login prompt (this will confirm that the FTP server is running0
type anonymous for the username and an email address for the password
see what you can see.
(this will confirm that the ftp server is setup for anonymous access)
quit (to close the connection)

Then repeat the above but this time use a username that you want the camera to login

this will confirm the functionality on the server.
From that point, you would have to determine whether the issue with the camera accessing the FTP server by repeating these test from another computer on the network.

Check the FTP server configuration in the image you posted, look at ftp authentication/authorization and check whether you allow anonymous access.

Author

Commented:
This is what comes up.CDM
Distinguished Expert 2017

Commented:
Check the authentication, authorization of the FTP server
It looks as though the FTP service connects, but closes the connection.

Author

Commented:
I deleted then recreated it using the default settings.   TCMD Resulthis is what I got.
Distinguished Expert 2017

Commented:
The hostname to which you connect is localhost not "local host" see your prior attempt.
ftp localhost
ftp the_system_name      This one is to use your LAN ip

Please post The output
netstat -an | find /I "listen"

Author

Commented:
OutputOutput
Distinguished Expert 2017

Commented:
So, you have FTP service running and listening on all.

Please try ftp localhost or ftp 192.168.0.21

If you do not get a prompt for a username, check the configuration authentication, authorization, ftp firewall support.

Author

Commented:
"check the configuration authentication, authorization, ftp firewall support."

Please provide instructions to do this.

I do not remember setting a password for the FTP.

Please see the snipits.CaptureCapture2
Distinguished Expert 2017

Commented:
Well, using localhost you are getting a prompt for login.
Try anonymous for the username, then an emailaddress it does not really mean which.

Please look at the FTP as you have in the image you posted first
There are items that deal with each section.
Look at the FTP firewall section to see whether you can enable access such that you will receive a  username prompt when you access
ftp 192.168.0.21
Currently, it looks because of the connection timeout error that the firewall is blocking it even though FTP service is listening on all IPs of the system based on the entry "0.0.0.0:21 listen" in the output to netstat -an | find /I "listen"

Author

Commented:
Not sure if this means anything, but I assume the folder that I want to send images to has to be shared.   When I tried to check this, I got the message that it cannot be shared.   Why not?
Distinguished Expert 2017

Commented:
Please clarify the meaning in which you use shared.

Commonly, iis related folders can not be shared through the network.
However, if you put your FTP directory within a location where the web can access it, the location if set to browseable will be accessible through the browser.

Author

Commented:
Sorry, Arnold.   I am not following you.   I do not understand most of your instructions.   Please transfer the question to another expert.
Distinguished Expert 2017

Commented:
This is not how EE works, this is a Site with people with some expertise respond to questions other people ask.

You posted an image from the IIS interface where you have sites and the FTP
when you select the FTPFTP site, you see in the right pane an assortment of different configuration setting from FTP authentication, FTP authorization, FTP firewall setttings, etc. At this point your FTP site is accessible through the use of localhost meaning it can only be accessed locally on the system.
To make the ftp service accessible from your LAN (other computers or devices within your location) you have to go through the FTP firewall portion and make sure FTP is allowed through the FIREWALL.


just for the point, added the the component on a windows 10 system. added the ftp site specified the anonymous access. ftp Authorization added a rule that the folder for anonymous access is write only.

and ftp was functional from that point.

I am not sure what happened when you added the FTP that it is not working.

You could try from the begining. Delete the current FTP site. or disable it  and add a new
specify a unique name, and where the data it will be using is.
Document_ftp_setup.rtf
Scott FellDeveloper & EE Moderator
Fellow 2018
Most Valuable Expert 2013

Commented:
First of all, are you just trying to get the images from the camera to your local computer?  Are you sure you need to use ftp?  I have an older 20D. It should just connect as if it was a usb device and then transferring is pretty easy.

For FTP, you do need to make sure the folder is set up for read and write for the specific user. This is different than sharing and may be the confusion.  Did you set read/write for the ftp user?

Author

Commented:
I want to have the camera send the images to the computer as they are taken.   From what I understand, using FTP is the most reliable way to do this, although there are other ways.   I had no problem setting it up under Windows 7.   I have tried all the options I can think of in the WFT to get it to send the images to the computer.   Every time I try it, I get Error 41 from the FTP server as displayed on the camera, despite disabling the firewall on the computer.
Distinguished Expert 2017

Commented:
Have you had a chance to follow the document I provided to setup the FTP from begining to end?
Developer & EE Moderator
Fellow 2018
Most Valuable Expert 2013
Commented:
Arnold really knows this type of thing better than I do. I would keep working with him.  

What I would do is grab another computer and try to ftp to the local ip.  Any error codes you get that way may be more meaningful. If you can ftp from another device, then it will be easier to troubleshoot from your camera. If you don't have another computer to test, download an ftp client for your android/ios and test.  

Beyond firewall, the only things I an think of are setting active/passive mode and making sure the folder you are pointing to with ftp is open for read and write for the ftp user.

See what error codes you get from another device and report back.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial