We help IT Professionals succeed at work.

not able to expend my volume in my VM

High Priority
70 Views
Last Modified: 2020-02-04
I am running a windows VM.  I have just extended the storage in my host server to the VM.
As you can see, I have over 1TB available, or that I should be able to expand my current drive, to use the unallocated space.
The problem is, why is the "extend volume" option greyed out?   I need to select Extend volume, so I can extend my volume.

Running windows server 2016

d1
d2
Comment
Watch Question

Seth SimmonsSr. Systems Administrator
CERTIFIED EXPERT
Commented:
why is the "extend volume" option greyed out?

the disk is MBR which has a maximum size of 2tb which is why the remaining space is useless
it is a disk design independent of the OS

make sure there is a good backup before doing any changes

Convert an MBR disk into a GPT disk
https://docs.microsoft.com/en-us/windows-server/storage/disk-management/change-an-mbr-disk-into-a-gpt-disk

once it is gpt, you need to change the vm setting to be efi
again, have a good backup before doing this
DanNetwork Engineer

Author

Commented:
So I'm getting this error message

disk
Lee W, MVPTechnology and Business Process Advisor
CERTIFIED EXPERT
Most Valuable Expert 2013
Commented:
You can't do that.  As the link Seth provided states:

   
Back up or move the data on the basic MBR disk you want to convert into a GPT disk.

    If the disk contains any partitions or volumes, right-click each and then click Delete Partition or Delete Volume.

What this really means is to convert the disk, the disk MUST BE EMPTY. You can't convert a disk with data on it!  You have to move all the data off it (including the OS) and then convert it.  Which, since this is the OS based disk, you really can't do without a system reload.

Basically, the server isn't designed well.  By putting the DATA on the C: drive you've caused yourself problems.  Data (especially in a VM) belongs on a separate virtual disk.

If you really must have a C: drive larger than 2TB, you'll need to completely re-load the server as a Gen2 VM.  That will force it to use UEFI and GPT disks which will allow volumes ovter 2TB for the C: drive.  Otherwise, you need to create a new Virtual hard disk, configure it as a GPT based disk (which you can do for NON-BOOT disks without reloading), move your data onto that virtual drive, and then (you should) shrink the C: drive down to something more reasonable - 100-150 GB.  It may require reconfiguring some things (depending on what the server does for you), but it's less drastic than a complete reload.

And in the future, strongly avoid putting data on the C: drive!
DanNetwork Engineer

Author

Commented:
Thanks lee for the details, it’s not converting the disk, but wiping it and starting fresh.  This is a joke from MS.
A true conversion should not require that you lose all data, as with OS data, you can’t just copy and paste.

This is for my WSUS server, but over the last year, this servers storage grew from 100gb to 2TB, all because of MS’s catalog files.

I will just have to create a new WSUS server and delete this one when the new one is in production.
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
The tool mbr2gpt.exe allows the conversion without losing data. You would need to mount the virtual hard drive on a system that supports mbr2gpt, namely win10 v1703 or higher.
CERTIFIED EXPERT

Commented:
Go to your virtual memory settings and turn off the pagefile.  The pagefile is a fixed file on disk and those blocks are marked as unmovable.  This is Windows equivalent to a fixed swapped partition, but created on the fly.  Once that pagefile is gone.  You should be able to convert the disk.

Also, for a VM, why do you even have a pagefile?  Unless you have limited RAM on your system, you should just size the RAM appropriately and turn off the pagefile.

To turn off the pagefile:
Go to the start menu and search for Advanced system Settings.
Select View Advanced System Settings.
The "System Properties" dialog box should open to the Advanced tab.
Click on the Settings button in the Performance box.
The Performance Options dialog box will open.
Select the Advanced tab
Click Change in the Virtual Memory box.
Click on the No paging file radio button.
DanNetwork Engineer

Author

Commented:
mcknife, thanks for the info, but I don't think it works with windows server, as I don't see that file anywhere in my windows /system32

serialband, so how does turning off the pagefile fix my issue with my partition not recognizing the other 1TB?
mbr

I think at this point, I might just have to build a new server and delete this one?
CERTIFIED EXPERT
Commented:
Sorry, I was thinking of a different thing.  The page file should still be removed in a VM.

You can't expand a Basic disk.  You need to change the disk type to dynamic.
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
"mcknife, thanks for the info, but I don't think it works with windows server, as I don't see that file anywhere in my windows /system32" - you misunderstood. I didn't tell you to use the server OS, but instead windows 10 1703 or higher in order to mount the virtual hard drive of the server.
DanNetwork Engineer

Author

Commented:
Mcknife, I see, so take the application from my windows 10 to the server, and run it on the server, got it.
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
No. You boot a windows 10 and mount that virtual hard drive.
DanNetwork Engineer

Author

Commented:
Got it, I wonder how long it takes to convert, as that means the server will be down during that timeframe.
CERTIFIED EXPERT
Distinguished Expert 2019
Commented:
Stage it. Create a vhdx, populate it with a server backup and just do it.
DanNetwork Engineer

Author

Commented:

Thanks guys for your help

Explore More ContentExplore courses, solutions, and other research materials related to this topic.