We help IT Professionals succeed at work.

Outlook 2010 security certificate warning

I have a client site that were forced to upgrade from Office 2003 and Windows 7 to Office 2010 and Windows 10.  They are connected to an older server running SBS 2011. I am getting the security alert that the security certificate has expired for their domain name whe starting Outlook 2010 and I cannot get it stop with the error message.  We have not needed a certificate in years until we went to Outlook 2010.  Is there anyway to disable the message at the workstation level?
Comment
Watch Question

Pete LongTechnical Consultant
Distinguished Expert 2019

Commented:
>>Is there anyway to disable the message at the workstation level?

No, you need to reissue a new certificate not Exchange, with the correct common name on it.

And because its SBS, normal Exchange procedures wont work properly, you will need to run some Wizard to regenerate a new certificate

Like so;
If using SBS2011 then

Start the Windows SBS2011 Standard Console
Click on the Network icon in the top bar, then click the Connectivity tab
Wait for the panel in the right to become active and then click on 'Fix My Network'
Let the wizard search for problems.
One of the problems it should find is the expired certificate.
Clear all the checkboxes except the certificate one and click Next
This will then re-issue a new self signed certificate on the server.
Ref: https://serverfault.com/questions/526221/renewing-sbs2011-exchange-self-signed-certificate-w-o-changing-home-page-in-ie

</P>

Author

Commented:
Pete, I ran the "Fix My Network" and it did come up with a certificate error about the web root.  I unchecked everything and let it fix and re-issue the certificate.  I rebooted the server and I still get the error message when starting Outlook.  Is there possibly another certificate that needs repairing?  When I run "Fix My Network" now it comes up with no errors that reference a certificate.
Scott SilvaNetwork Administrator

Commented:
You either need a real cert for client connections, or you have to go to each client and turn off "Encrypt data between Microsoft Outlook and Microsoft Exchange.
Annotation-2020-02-07-101509.png
I didnt have any luck with any of the recommendations.  I ended up purchasing a certificate from godaddy and they helped me install it.  Thanks for everyones help!
Scott SilvaNetwork Administrator
Commented:
Funny... Part of my suggestion was "you need a real cert"...

There are free options, but you already resolved it...

Author

Commented:
Thanks for all your help!!