Link to home
Start Free TrialLog in
Avatar of mlcktmguy
mlcktmguyFlag for United States of America

asked on

New Win 10 Pro Install, 'We're sorry access is not allowed with Edge due to security concerns."

I am developer, upgrading my Office computers to Win 10 Pro.  I ran the install opting to retain my apps and data.  One of the most important things I do is remoting into clients system for problem resolution installing updates, etc..

I installed Win 10 Pro on one of the laptops in my office.  I am trying to remote in to one of my clientsusing a shortcut retained during the install.

I see the first screen 'C'itrix Netscaler Gateway' and enter my user id and password.  Prior to WIn 10,  after entering my logon info I would get a push to my iPhone from DUO.  That doesn't happen now.  Instead I get the message 'We're sorry access is not allowed with Edge due to security concerns."  I can see the DUO screen disabled in the background behind the message.

What do I need to do to get this to work.
Avatar of Cliff Galiher
Cliff Galiher
Flag of United States of America image

Don't use the built in administrator account.
ASKER CERTIFIED SOLUTION
Avatar of McKnife
McKnife
Flag of Germany image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of mlcktmguy

ASKER

Thanks for the responses.
"Don't use the built in administrator account. "  I don't know what that means or how not to use it.  I am logging in to the machine the same way I always did.

I use firefox, which is on the list of 'acceptable to Edge' but I'm still getting the error.
Windows 10 doesn't allow any store apps, including edge, to install or run under the account "Administrator"

Logging in with that account has been considered a bad security practice for decades and has been increasingly discouraged with each new version of windows.  You can create other accounts and add them to the administrators group.  That's fine. Just the special "Administrator" account I'd particularly bad for reasons not worth going into here.
McKnife:  I thought I was changing my default browser to Firefox but didn't realize it kept getting reset to Edge.  
When I properly changed it I was received my DUO push and was able to connect.

Cliff:  Thanks, that good information and it sounds like that my bite me again somewhere else.
McKnife:  I thought I had revised my default browser to Firefox but didn't realize it kept getting set back to 'Edge'

When I properly changed it to Firefox I received the DUO push and was able to connect.

Cliff Galiher: Thanks you, that's good information and may be causing me issues as I work more on this machine.