We help IT Professionals succeed at work.

Install the Android Studio 3.5.3 and HAXM

Khan Consultoria
on
Hello Guys,

I was working fine with Android Studio version 3.5.2, but I needed to exchange my HD to SSD and then I installled the windows 10 again.

I download the Android Studio, 3.5.3 and when I installed it with HAXM 7.5.4, a process that it does automatically when Selected to install,

it can't complete the installation and gives me that error:

Unable to install Intel HAXM
Unknown Error
Please file a bug against Android Studio

What should I do?

Regards
Alex
Comment
Watch Question

AlexA lack of information provides a lack of a decent solution.
BRONZE EXPERT

Commented:
I'm going to go with file a bug against Android Studio, unless you have something within your event logs to give us more than an "Unknown Error", it's going to be a little hard to resolve.

Regards
Alex

Author

Commented:
Hi Alex,

I got those step lines when I tried to install it:

Preparing "Install Intel x86 Emulator Accelerator (HAXM installer) (revision: 7.5.4)".
Downloading https://dl.google.com/android/repository/extras/intel/haxm-windows_v7_5_4.zip
"Install Intel x86 Emulator Accelerator (HAXM installer) (revision: 7.5.4)" ready.
Installing Intel x86 Emulator Accelerator (HAXM installer) in C:\Users\alexh\AppData\Local\Android\Sdk\extras\intel\Hardware_Accelerated_Execution_Manager
"Install Intel x86 Emulator Accelerator (HAXM installer) (revision: 7.5.4)" complete.
"Install Intel x86 Emulator Accelerator (HAXM installer) (revision: 7.5.4)" finished.
Parsing C:\Users\alexh\AppData\Local\Android\Sdk\build-tools\29.0.2\package.xml
Parsing C:\Users\alexh\AppData\Local\Android\Sdk\emulator\package.xml
Parsing C:\Users\alexh\AppData\Local\Android\Sdk\extras\google\google_play_services\package.xml
Parsing C:\Users\alexh\AppData\Local\Android\Sdk\extras\google\usb_driver\package.xml
Parsing C:\Users\alexh\AppData\Local\Android\Sdk\extras\intel\Hardware_Accelerated_Execution_Manager\package.xml
Parsing C:\Users\alexh\AppData\Local\Android\Sdk\patcher\v4\package.xml
Parsing C:\Users\alexh\AppData\Local\Android\Sdk\platform-tools\package.xml
Parsing C:\Users\alexh\AppData\Local\Android\Sdk\platforms\android-26\package.xml
Parsing C:\Users\alexh\AppData\Local\Android\Sdk\platforms\android-29\package.xml
Parsing C:\Users\alexh\AppData\Local\Android\Sdk\sources\android-29\package.xml
Parsing C:\Users\alexh\AppData\Local\Android\Sdk\system-images\android-26\google_apis\x86\package.xml
Parsing C:\Users\alexh\AppData\Local\Android\Sdk\system-images\android-26\google_apis_playstore\x86\package.xml
Parsing C:\Users\alexh\AppData\Local\Android\Sdk\tools\package.xml
Android SDK is up to date.
Unable to install Intel HAXM
Unknown Error
Please file a bug against Android Studio.
Done

Open in new window


that helps?
AlexA lack of information provides a lack of a decent solution.
BRONZE EXPERT

Commented:
try installing the HAXM from here first


https://github.com/intel/haxm

Author

Commented:
Alex,

I have a lot of folders, there is no any install. Do you have any idea how to install it in Android Studio ?
AlexA lack of information provides a lack of a decent solution.
BRONZE EXPERT

Commented:
https://github.com/intel/haxm/releases/tag/v7.5.4

In realeases, download it here.

Regards
Alex

Author

Commented:
I installed it in silence mode,

I opened my Android Studio and in SDK the option HAXM installer is not checked,

Should it be checked after that instalation?
AlexA lack of information provides a lack of a decent solution.
BRONZE EXPERT

Commented:
I have no idea, but at least it's opening now right?

Put a tick in it, see what happens.

Author

Commented:
Alex,

When I tick the Intel x86 Emulator Accelerator ( HAXM installer) in SDK tools and Apply it, the Android Studio download the file, open the window Emulator Settings and give me the recommended size 2.0 GB and I click the button next, it tries to install it but fails giving me that list that I placed here.

Author

Commented:
I think it is not possible to download the version 3.5.2 anymore, I tried to find it and I haven't had any success on it. May this version is ok as it was for me before updating the version to 3.5.3

Author

Commented:
Thanks for your help too, I am installing the windows again and then the Android Studio.
My notebook has the technology for Virtual Machine in the BIOS and it is activated.
Any news I will report here,
AlexA lack of information provides a lack of a decent solution.
BRONZE EXPERT

Commented:
I wouldn't bother doing that, it's unlikely it's your machine, it worked before right?

Speak with Android Studio
Commented:
Hello Alex,

I got it. The problem that I was facing was due to my start installation.

I solved it downloading a visual C++ redistribution and all went fine.

Thanks a lot for your help

Author

Commented:
Thanks Alex for you help,

I have another thread, I appreciate a lot your help

Explore More ContentExplore courses, solutions, and other research materials related to this topic.