VMWare ESXi Upgrade - [VibFormatError] invalid payload

Ryan Swift
Ryan Swift used Ask the Experts™
on
We currently have a host with VMware ESXi, 5.0.0, 469512

I am attempting to upgrade to VMware ESXi 6.7 via SHH.  I tried one method of installing via SHH having it download from VMware's site as well as trying to upgrade from an offline installer on the datastore.  Both attempts give me the same error:


~ # esxcli software vib update -d /vmfs/volumes/datastore/ISO-IMAGES/VMware-ESXi-6.7.0-8169922-depot.zip

 [VibFormatError]
 VIB 'esx-base-6.7.0-0.0.8169922' has invalid payload:
 Please refer to the log file for more details.

Logs are not showing anything helpful.  Any ideas?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017

Commented:
IT Manager
Commented:
I was doing exactly as your HOW TO's are stated Andrew, but that did not ultimately resolve it for me.

For what ever reason I ended up needing to upgrade from 5.0 - 5.5, then from 5.5 I was able to ugprade to 6.7.
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017

Commented:
No upgrade path from 5.0 to 6.7! (because 5.0 is end of life)

and even with 6.7, sometimes cannot go from GA to U3! (direct).

Upgrades offline are also different from iso upgrades e.g. boot the server!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial