Exchange 2016  Event ID 1033 Repeating

Thomas Grassi
Thomas Grassi used Ask the Experts™
on
Exchange 2016 CU10  DAG 2 Nodes
VMware 6.5
Kemp Load Balancer


I am getting this warning over an over again

Log Name:      Application
Source:        MSExchange ActiveSync
Date:          12/20/2019 2:36:09 PM
Event ID:      1033
Task Category: Configuration
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      TGCS021-N1.our.network.tgcsnet.com
Description:
The setting SupportedIPMTypes in the Web.Config file was missing.  Using default value of System.Collections.Generic.List`1[System.String].
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="MSExchange ActiveSync" />
    <EventID Qualifiers="32772">1033</EventID>
    <Level>3</Level>
    <Task>2</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2019-12-20T19:36:09.696918100Z" />
    <EventRecordID>7642358</EventRecordID>
    <Channel>Application</Channel>
    <Computer>TGCS021-N1.our.network.tgcsnet.com</Computer>
    <Security />
  </System>
  <EventData>
    <Data>SupportedIPMTypes</Data>
    <Data>System.Collections.Generic.List`1[System.String]</Data>
  </EventData>
</Event>

Open in new window




I tried adding this to the web.config file

<appSettings>	
    <add key="SupportedIPMTypes" value=""></add>
    <add key="LiveIdBasicAuthModule.ApplicationName" value=""></add>
    <add key="UserWorkloadManager.PermitSynchronousTaskExecution" value="false" />
    <!-- Config file for tracing -->

Open in new window




Based on my test, issue could be reproduced by either restarting the MSExchangeSyncAppPool application pool or rebooting the server. Same issue in Exchange 2016 CU12.

I am currently at CU10   I have CU12 available to install

But what I found so far is it is the same on CU12  

Any Ideas or thoughts?

Thank you

Tom


PS I am already Ignoring the pesty Event Id 3028 event killbits which that's all the answer I got on that one is to ignore it.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Edward van BiljonMessaging and Collaboration Technical Lead (Exchange MVP & MCT)

Commented:
Hi Tom

If you go to this directory: C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\Sync and rename web.config to old and then copy the .bak one and rename it to web.config and do an IISReset, does the same happen?

CU15 is available for 2016, CU14 seems to be running smoothly as well, I would advise upgrading as CU12 and 13 had quite a few fixes in them.
Thomas GrassiSystems Administrator

Author

Commented:
ED

Thank you

I see CU16 is available  should I go with 15 or 16 ?
Edward van BiljonMessaging and Collaboration Technical Lead (Exchange MVP & MCT)

Commented:
I like to stay 1 version behind the latest so go for 15
How to Generate Services Revenue the Easiest Way

This Tuesday! Learn key insights about modern cyber protection services & gain practical strategies to skyrocket business:

- What it takes to build a cloud service portfolio
- How to determine which services will help your unique business grow
- Various use-cases and examples

Thomas GrassiSystems Administrator

Author

Commented:
Ed just downloaded CU15

Will apply in next week

Thanks
Edward van BiljonMessaging and Collaboration Technical Lead (Exchange MVP & MCT)

Commented:
no problem, if you need help with anything let me know. 😁
Thomas GrassiSystems Administrator

Author

Commented:
Ed

After both Nodes have been updated to CU15 my databases are not functional fully

Unable to move them

On node 2 I have this

[PS] C:\Windows\system32>get-ServerComponentState -Identity TGCS021-N2.our.network.tgcsnet.com

Server                             Component                  State
------                             ---------                  -----
TGCS021-N2.our.network.tgcsnet.com ServerWideOffline          Inactive
TGCS021-N2.our.network.tgcsnet.com HubTransport               Inactive
TGCS021-N2.our.network.tgcsnet.com FrontendTransport          Inactive
TGCS021-N2.our.network.tgcsnet.com Monitoring                 Active
TGCS021-N2.our.network.tgcsnet.com RecoveryActionsEnabled     Active
TGCS021-N2.our.network.tgcsnet.com AutoDiscoverProxy          Inactive
TGCS021-N2.our.network.tgcsnet.com ActiveSyncProxy            Inactive
TGCS021-N2.our.network.tgcsnet.com EcpProxy                   Inactive
TGCS021-N2.our.network.tgcsnet.com EwsProxy                   Inactive
TGCS021-N2.our.network.tgcsnet.com ImapProxy                  Inactive
TGCS021-N2.our.network.tgcsnet.com OabProxy                   Inactive
TGCS021-N2.our.network.tgcsnet.com OwaProxy                   Inactive
TGCS021-N2.our.network.tgcsnet.com PopProxy                   Inactive
TGCS021-N2.our.network.tgcsnet.com PushNotificationsProxy     Inactive
TGCS021-N2.our.network.tgcsnet.com RpsProxy                   Inactive
TGCS021-N2.our.network.tgcsnet.com RwsProxy                   Inactive
TGCS021-N2.our.network.tgcsnet.com RpcProxy                   Inactive
TGCS021-N2.our.network.tgcsnet.com UMCallRouter               Inactive
TGCS021-N2.our.network.tgcsnet.com XropProxy                  Inactive
TGCS021-N2.our.network.tgcsnet.com HttpProxyAvailabilityGroup Inactive
TGCS021-N2.our.network.tgcsnet.com ForwardSyncDaemon          Inactive
TGCS021-N2.our.network.tgcsnet.com ProvisioningRps            Inactive
TGCS021-N2.our.network.tgcsnet.com MapiProxy                  Inactive
TGCS021-N2.our.network.tgcsnet.com EdgeTransport              Inactive
TGCS021-N2.our.network.tgcsnet.com HighAvailability           Inactive
TGCS021-N2.our.network.tgcsnet.com SharedCache                Inactive
TGCS021-N2.our.network.tgcsnet.com MailboxDeliveryProxy       Inactive
TGCS021-N2.our.network.tgcsnet.com RoutingUpdates             Inactive
TGCS021-N2.our.network.tgcsnet.com RestProxy                  Inactive
TGCS021-N2.our.network.tgcsnet.com DefaultProxy               Inactive
TGCS021-N2.our.network.tgcsnet.com Lsass                      Inactive
TGCS021-N2.our.network.tgcsnet.com RoutingService             Inactive
TGCS021-N2.our.network.tgcsnet.com E4EProxy                   Inactive
TGCS021-N2.our.network.tgcsnet.com CafeLAMv2                  Inactive
TGCS021-N2.our.network.tgcsnet.com LogExportProvider          Inactive

Open in new window



I ran this command

[PS] C:\Windows\system32>Get-ServerComponentState "TGCS021-N1" | % { Set-ServerComponentState "TGCS021-N1" -Requester Fu
nctional -Component $_.Component -State Active }

Open in new window



No change

This is causing email flow problems also.

Need the databases on the correct NODE

Any ideas
Edward van BiljonMessaging and Collaboration Technical Lead (Exchange MVP & MCT)

Commented:
you can change the activation preference on the database either using the eac or ems
Thomas GrassiSystems Administrator

Author

Commented:
Ed,

Hello

I tried that and it fails to do so.

From powershell what is the command syntax? I used this

[PS] C:\Windows\system32>move-activemailboxdatabase "Mailbox Database 1584545747" -ActivateOnServer TGCS021-N2 -MountDialOverride:GoodAvailability

Identity        ActiveServerAtS ActiveServerAtE Status     NumberOfLogsLost   RecoveryPoint MountStatus MountStatus
                tart            nd                                            Objective     AtMoveStart AtMoveEnd
--------        --------------- --------------- ------     ----------------   ------------- ----------- -----------
Mailbox         TGCS021-N1      TGCS021-N1      Failed                                      Mounted     Mounted
Database
1584545747
An Active Manager operation failed. Error: The database action failed. Error: An error occurred while trying to
validate the specified database copy for possible activation. Error:
        TGCS021-N2:
        Database copy 'Mailbox Database 1584545747' on Server 'TGCS021-N2' component (HighAvailability) state is
offline. If you need to activate this copy of the database, you can use Set-ServerComponentState -Component
'HighAvailability' -State 'Active' and retry Move-ActiveMailboxDatabase.
         [Database: Mailbox Database 1584545747, Server: TGCS021-N1.our.network.tgcsnet.com]
    + CategoryInfo          : InvalidOperation: (Mailbox Database 1584545747:ADObjectId) [Move-ActiveMailboxDatabase],
    AmDbActionWrapperException
    + FullyQualifiedErrorId : [Server=TGCS021-N1,RequestId=c76c9cdf-3205-4f50-b04c-fbdd04e2e112,TimeStamp=12/24/2019 9
   :19:44 PM] [FailureCategory=Cmdlet-AmDbActionWrapperException] 77FBED09,Microsoft.Exchange.Management.SystemConfig
  urationTasks.MoveActiveMailboxDatabase
    + PSComputerName        : tgcs021-n1.our.network.tgcsnet.com


I opened a new question

https://www.experts-exchange.com/questions/29167963/Exchange-2016-CU15-ServerComponentState-stuck-on-inactive.html

Have details there.

Thank you

Merry Christmas.
Thomas GrassiSystems Administrator

Author

Commented:
Ed closed the other case I figured the inactive components issue Node 2 was in maint mode ran a script to remove maint mode.

Now on node  2

[PS] C:\util>Get-mailboxdatabasecopystatus

Name                                          Status          CopyQueue ReplayQueue LastInspectedLogTime   ContentIndex
                                                              Length    Length                             State
----                                          ------          --------- ----------- --------------------   ------------
Mailbox Database 1584545747\TGCS021-N2        Healthy         0         0           12/24/2019 9:46:53 PM  Healthy
Mailbox Database TGCSNET\TGCS021-N2           Healthy         0         0           12/24/2019 9:40:08 PM  Healthy
Mailbox Database 0573979367\TGCS021-N2        FailedAndSuspen 310       1           12/21/2019 2:07:18 PM  Suspended
                                              ded
Antispam-2016\TGCS021-N2                      FailedAndSuspen 307       1           12/21/2019 4:22:21 PM  Suspended
                                              ded
TGCSNET-Journal2016\TGCS021-N2                FailedAndSuspen 326       1           12/21/2019 2:22:19 PM  Suspended
                                              ded


[PS] C:\util>Resume-MailboxDatabaseCopy -Identity 0573979367\TGCS021-N2
The operation couldn't be performed because object '0573979367\TGCS021-N2' couldn't be found on
'TGCS011.our.network.tgcsnet.com'.
    + CategoryInfo          : NotSpecified: (:) [Resume-MailboxDatabaseCopy], ManagementObjectNotFoundException
    + FullyQualifiedErrorId : [Server=TGCS021-N2,RequestId=f103a9b8-eb8d-4feb-8d3e-b89d8522590f,TimeStamp=12/25/2019 2
   :56:18 AM] [FailureCategory=Cmdlet-ManagementObjectNotFoundException] C4591F30,Microsoft.Exchange.Management.Syste
  mConfigurationTasks.ResumeDatabaseCopy
    + PSComputerName        : tgcs021-n2.our.network.tgcsnet.com

[PS] C:\util>
Shreedhar EtteTechnical Manager
Top Expert 2010

Commented:
Looks like in last comment database name was not mentioned properly.

Please execute this command and see:
Resume-MailboxDatabaseCopy -Identity "Mailbox Database 0573979367"
Thomas GrassiSystems Administrator

Author

Commented:
Results


[PS] C:\Windows\system32>Get-mailboxdatabasecopystatus

Name                                          Status          CopyQueue ReplayQueue LastInspectedLogTime   ContentIndex
                                                              Length    Length                             State
----                                          ------          --------- ----------- --------------------   ------------
Mailbox Database 1584545747\TGCS021-N2        Mounted         0         0                                  Healthy
Mailbox Database TGCSNET\TGCS021-N2           Healthy         0         0           12/26/2019 9:02:58 AM  Healthy
Mailbox Database 0573979367\TGCS021-N2        FailedAndSuspen 449       1           12/21/2019 2:07:18 PM  Suspended
                                              ded
Antispam-2016\TGCS021-N2                      FailedAndSuspen 445       1           12/21/2019 4:22:21 PM  Suspended
                                              ded
TGCSNET-Journal2016\TGCS021-N2                FailedAndSuspen 465       1           12/21/2019 2:22:19 PM  Suspended
                                              ded


[PS] C:\Windows\system32>Resume-MailboxDatabaseCopy -Identity "Mailbox Database 0573979367"
The operation couldn't be performed because 'Mailbox Database 0573979367\*' matches multiple entries.
    + CategoryInfo          : NotSpecified: (:) [Resume-MailboxDatabaseCopy], ManagementObjectAmbiguousException
    + FullyQualifiedErrorId : [Server=TGCS021-N2,RequestId=22eff655-294c-4a12-9e49-2a977b176818,TimeStamp=12/26/2019 2
   :07:37 PM] [FailureCategory=Cmdlet-ManagementObjectAmbiguousException] BE654365,Microsoft.Exchange.Management.Syst
  emConfigurationTasks.ResumeDatabaseCopy
    + PSComputerName        : tgcs021-n2.our.network.tgcsnet.com

[PS] C:\Windows\system32>
Technical Manager
Top Expert 2010
Commented:
Sorry Execute this:

Resume-MailboxDatabaseCopy -Identity "Mailbox Database 0573979367\TGCS021-N2"
Thomas GrassiSystems Administrator

Author

Commented:
results

[PS] C:\Windows\system32>Resume-MailboxDatabaseCopy -Identity "Mailbox Database 0573979367\TGCS021-N2"
A server-side administrative operation has failed. The database copy could not be resumed because of a previous error
that is preventing the resume operation. Error: At '12/21/2019 2:07:19 PM' the Exchange store database 'Mailbox
Database 0573979367' copy on this server appears to be inconsistent with the active database copy or is corrupted. For
more detail about the failure, consult the Event log on the server for other storage and "ExchangeStoreDb" events. The
passive database copy has been suspended.
 [Database: 02134654-fd8c-4dc4-92ec-f9e899c70a7d, Server: TGCS021-N2.our.network.tgcsnet.com]
    + CategoryInfo          : NotSpecified: (:) [Resume-MailboxDatabaseCopy], ReplayServiceResumeBlockedException
    + FullyQualifiedErrorId : [Server=TGCS021-N2,RequestId=22eff655-294c-4a12-9e49-2a977b176818,TimeStamp=12/26/2019 3
   :08:43 PM] [FailureCategory=Cmdlet-ReplayServiceResumeBlockedException] D0273CEB,Microsoft.Exchange.Management.Sys
  temConfigurationTasks.ResumeDatabaseCopy
    + PSComputerName        : tgcs021-n2.our.network.tgcsnet.com
Thomas GrassiSystems Administrator

Author

Commented:
Should I reseed the database on NODE 2?

use Update-MailboxDatabaseCopy   -Identity "Mailbox Database 0573979367\TGCS021-N2"    

But this needs the database to be deleted on NODE 2. is this safe to do?
Thomas GrassiSystems Administrator

Author

Commented:
Update

I ran this on one of the failed databases on Node 2

Update-MailboxDatabaseCopy   -Identity "Antispam-2016\TGCS021-N2"   -DeleteExistingFiles  -BeginSeed


[PS] C:\Windows\system32>Get-mailboxdatabasecopystatus

Name                                          Status          CopyQueue ReplayQueue LastInspectedLogTime   ContentIndex
                                                              Length    Length                             State
----                                          ------          --------- ----------- --------------------   ------------
Mailbox Database 1584545747\TGCS021-N2        Mounted         0         0                                  Healthy
Mailbox Database TGCSNET\TGCS021-N2           Healthy         0         0           12/26/2019 10:10:56 PM Healthy
Mailbox Database 0573979367\TGCS021-N2        FailedAndSuspen 500       1           12/21/2019 2:07:18 PM  Suspended
                                              ded
Antispam-2016\TGCS021-N2                      Healthy         0         92          12/26/2019 10:16:00 PM Failed
TGCSNET-Journal2016\TGCS021-N2                FailedAndSuspen 516       1           12/21/2019 2:22:19 PM  Suspended
                                              ded


The Status went to Healthy but the ContentIndex State shows failed

So I ran this

Update-MailboxDatabaseCopy   -Identity "Antispam-2016\TGCS021-N2" -CatalogOnly      

ContentIndex State still shows Failed.

How do I clear this and make it healthy again?
Shreedhar EtteTechnical Manager
Top Expert 2010

Commented:
If content index failed after running Update-MailboxDatabaseCopy for CatalogOnly then only option is to rename contentindex fielder and rebuild.

Please follow "Reseed the content index catalog if there is only one copy of the mailbox database" of the article https://docs.microsoft.com/en-us/exchange/reseed-the-search-catalog-exchange-2013-help
Thomas GrassiSystems Administrator

Author

Commented:
Shreedhar

I have healthy Mailboxdatabasecopies now on all databases.   Thank you for your help

Ed

CU15 now installed on both NODES  still getting 1033 event   will post new question later today.
Edward van BiljonMessaging and Collaboration Technical Lead (Exchange MVP & MCT)

Commented:
Hi Thomas

Sorry been offline. The mobile app had the chat button over the send button so couldn’t respond.

Post the new question and I will take a look.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial