printer port problem

Hashim Hadi
Hashim Hadi used Ask the Experts™
on
I added a network printer on my pc as tcp/ip printer .. the next day the port name changed to the name of the printer and in the IP address field also I found the printer name . I tried to ping the printer by its name and I failed then I deleted the port and added a new tcp/ip port and it worked again . my question is why the port configuration got changed I mean the IP address in the port configuration got changed to the printer name . is it from WSD (the discovery port) on the printer properties?

note: the printer is also installed on a domain server and listed in the directory and shared from it. but in my pc  I added it as network not as shared printer.

 printer.png
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Distinguished Expert 2017
Commented:
I suspect this is the result of the installation of the canon driver/software that setup the printer through the canon printer, scanner discovery.

It is also as you note possible through SSD discovery, though I think that would gave used the IP not a name/ dev ref.
I would add a new TCP/IP port.  If it searches for a printer, just tell it right away that "my printer isn't listed" to move on.  When you get to the part (Device Type pulldown) bring up: “TCP/IP Device”  and not AUTOMATIC.
That should keep it in that mode thereafter.  The objective is to avoid it using WSD.  This seems to always work.
That port looks strange. For LPR the port number should be 515; port 9100 is normally for the RAW setting.

I would suggest the same fix as Fred: create a new port. Raw protocol is preferred, and WSD is to be avoided. Use LPR/515 if needed.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial