Single ESXi 5.x host can't boot from USB because Fatal error: 33 (Inconsistent data). No VM backups available.

Alessandro Scafaria
Alessandro Scafaria used Ask the Experts™
on
Hello folks! Glad to be back asking you a question!
I need your help on this very small production system, that is currently down.

#Background
Only 1 ESXi physical host present (no VCenter), configured to boot ESXi from an USB drive and VMs data are into the RAID built with SAS HDDs of the server itself.
No VM backups since 1 year (I know....I know.....bad sysadmins, but what can we do now). There is a VEEAM VM that "was" backing up the VMs into a Ethernet NAS, but from logs backups are not happening since 1 year or so.
Not much environment configuration (I don't even know the ESXi version deployed on this unique host, but at least I have physical access to it).
According to sysadmins, installation happened back in May 2015 and no updates to platform got performed, so I suspect it should be ESXi 5.5 (mostly) or 5.1.


#Problem

  Host stopped booting from the USB because of Fatal error: 33 (Inconsistent data).
I started following this https://www.experts-exchange.com/articles/13595/HOW-TO-Fix-the-Error-loading-s-v00-Fatal-error-33-Inconsistent-data-in-the-VMware-vSphere-Hypervisor.html ,
I created an image of the "faulty USB" using the tool suggested in that Wiki and I've restored it into 2 different Kingstone USB flash drives 16GB/32GB (to be sure to avoid any potential hardware problem on the new flash drives I chose).
I followed Step2 (Confirm the USB flash drive or SD card is Faulty using a virtual machine), that was suggesting to confirm if the file reported in the error was actually corrupted.
If I run the test using the production USB, I get a repro of the original error (Error loading /s.v00 Fatal error: 33 (Inconsistent data)).
If I run the same test using any of the 2 different USB flash drives on which I've restored the image of the Production USB, in all cases VMware starts in recovery mode and I get immediately:
BANK5: invalid configuration.
BANK6: not a VMware boot bank.
No hypervisor found.

I've attached a screenshot of this other error for reference.

What do you suggest to unblock myself?

Thanks so much for your time.
Screenshot_Esxi_error.PNG
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2014

Commented:
Seems awfully complicated when you can just reinstall VMware. As Andrew's article states you would have to configure it but on a single server installation that should only take a few minutes.
VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017
Commented:
Your restore is not restoring the image correctly.

as defined by this...

BANK5: invalid configuration.
BANK6: not a VMware boot bank.
No hypervisor found.

The simplest method to get you out of this issue, is to just use a new USB flash drive, and re-install ESXi, using the same version if possible as before.

BUT, when you re-install be very careful because the install will prompt you and state it's found a current VMFS partition (datastore) this is where all your virtual machines are stored. Select Yes to Preserve (do not overwrite).

and then start the server, browse the datastore, select the virtual machines and add to inventory.

You may also need to perform some configuration, depending upon how complicated your installation was.
Top Expert 2014
Commented:
You can always remove the disks before installing and put them back afterwards, then the installer won't even threaten to wipe the data out.
Alessandro ScafariaInfrastructure Premier Field Administrator
Top Expert 2015

Author

Commented:
Thanks guys. I've just reinstalled using a new USB removing the disks first and then pulling them back. Worked like a charm.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial