IE 11 opens up instead of Chrome

Basem Khawaja
Basem Khawaja used Ask the Experts™
on
I would like to know why when I click on a message saying "if you are having a problem viewing this email in outlook click here to open in browser. See image capture. The email opens in IE 11 not in Chrome as it would have been if I would to click on the email links if it would have been displayed otherwise. My default browser is Chrome.

Thank you,

Basem Khawaja, R.Ph.

Email opens in IE 11.jpg
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Dimitris MaleasData recovery engineer

Commented:
You will need to change the default app type for .mht and .mhtml as this file type is opened in Outlook when you click an html link.

1. Windows Key+R
2. Copy the below and paste in Run Window > Enter
control /name Microsoft.DefaultPrograms /page pageFileAssoc
3. Scroll down to reach .mht and select .mht > Change Program
4. Click More apps
5. Click Look for another app on this PC
6. Now Start Firefox
7. CTRL+SHIFT+ESC to invoke Task Manager
8. Under Details tab, locate Firefox > Right Click > Open File Location
Now this is the path where Firefox.exe is. This is what you need to select in Step 5
9. Repeat the steps for .mhtml also
10. Restart your computer
Dimitris MaleasData recovery engineer

Commented:
OR follow this:
1.png2.png
Dimitris MaleasData recovery engineer

Commented:
If it is not working try below:
    Right-click on the Google Chrome Desktop shortcut.
    Select Properties from the context menu.
    Modify the Target text box value. Add the command line argument --save-page-as-mhtml after the chrome.exe portion.
    Click OK and confirm the UAC prompt.
    Restart the browser using your new shortcut.

Now, right-click on any area of the page and select "Save as", and ensure that the Save dialog has the "Web Page, single file" file type selected by default.
Become a Microsoft Certified Solutions Expert

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

Basem KhawajaClinical Pharmacist

Author

Commented:
Hi Dimitris

I tried the first 2 solutions you suggested and unfortunately there was only 2 options when I clicked on the Internet Explorer that was there by default. The 2 options were 1. IE and 2.Choose another app from the Microsoft Store. There was no Chrome to shoose from. One question though how do you know to click on .mht and .mhtml from the message that says to click here to open in browser/  

Let me try the third solution and I will get back to you. Thank you.
Basem KhawajaClinical Pharmacist

Author

Commented:
If it is not working try below:
    Right-click on the Google Chrome Desktop shortcut.
    Select Properties from the context menu.
    Modify the Target text box value. Add the command line argument --save-page-as-mhtml after the chrome.exe portion.
    Click OK and confirm the UAC prompt.
    Restart the browser using your new shortcut.

Now, right-click on any area of the page and select "Save as", and ensure that the Save dialog has the "Web Page, single file" file type selected by default.
I have some questions that I would like you to clarify please:
1.In the target field , do I need to enter the --(Dash Dash) before the command line after chrome .exe or the 2 Quotation Marks in the beginning and the end of the command like this "--save-page-as-mhtml".

2.Now, right-click on any area of the page-What page are you referring to?? I am not clear on this part.

Please clarify and let me know.
Thank you Dimitris.
Dimitris MaleasData recovery engineer

Commented:
Hi Basem,
Well i will give you one better solution.
Open notepad, write 2-3 char and save the file as A.mhtml
Open notepad, write 2-3 char and save the file as B.mht
Now you have 2 files (A.mhtml and B.mht)
Make right click on A.mhtml --> Open with --> More apps --> Choose Chrome and check "Always use this app..." (If Chrome does not esxist make "Look for another app..." and find Chrome (usually C:\Program Files (x86)\Google\Chrome\Application"
Make the same for .mht file.
Check the result in Outlook.

Let me know if you have problem.
Basem KhawajaClinical Pharmacist

Author

Commented:
Dimitris

The solution that you provided me partially worked. I was able to open the email in Chrome. However when it opened it only showed the email contents as text only not HTML. No pictures and images like the actual email. The same thing happened with other emails whenever I tried to view the email in the browser. I am not sure what is going on ? Please help me. Also the 2 Notepad files that I created , whenever I tried to open hem . They opened but nothing was inside the document. Do you know why did this happen? lastly, If I needed to open the email back in IE 11 , how do I go back to do so with IE 11? The email initially showed up just fine when it opened in IE 11 but NOT Chrome.

Thank you Dimitris.
Dimitris MaleasData recovery engineer

Commented:
Hi Basem,
To change it just start writing "Choose default app...
5.pngAnd inside go down to file types since .mht. Then change it to Internet explorer
Basem KhawajaClinical Pharmacist

Author

Commented:
Hi Dimitris

With all due respect I was able to change the file type prior to your reply. What I hoping to receive is an explanation why when changing to chrome the email only shows text but not HTML content like images and pictures. Can you please see if you can help figure this out? Also, when I opened the noted pad the typed message that I entered did not show up. Only BLANK note pad opened up with Chrome.

Thank you,

Basem
Basem KhawajaClinical Pharmacist

Author

Commented:
Can anyone help me please?
IT Professional | Freelance Journalist | Looking for Opportunities
Distinguished Expert 2018
Commented:
Hi Basem,

The steps shown above by Dimitris are perfectly correct and exactly what I would have suggested as well.

Reasoning: Microsoft Outlook will always open emails in Internet Explorer by default as that is by design.

You can also edit some registry settings to change that default behavior but I don't recommend doing it as it can cause other issues in Windows not related to Outlook. One thing to remember is that the View in Browser function is only available for email messages that were formatted in the HTML format. The option is not available for Text formatted messages.

You may also lose some functionality if you force Outlook email messages to open in Chrome (just as the problem you described and experienced in this comment) so consider that if you decide to continue wanting to alter Windows so that email messages will always open with Chrome instead of IE.

Regards, Andrew
Basem KhawajaClinical Pharmacist

Author

Commented:
Thank you gentlemen.
Basem KhawajaClinical Pharmacist

Author

Commented:
Thank you gentlemen.
Basem KhawajaClinical Pharmacist

Author

Commented:
Thank you Andrew. I will leave it to open in MS IE 11 since that was the default and I don't want to miss the HTML functionality when opened in Chrome.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial