Link to home
Create AccountLog in
Avatar of supportmail
supportmailFlag for United States of America

asked on

Win7-Win10 Upgrades Fail with Autologon Configured

Hello, we use SysInternals Autologon tool to configure generic user accounts to automatically log into Windows on many kiosk type PCs. I'm working on automated Win7 to Win10 (Pro OS) upgrades using SCCM task sequences, and the kiosk PCs configured to log in automatically are coming out of the upgrade unable to log into Windows.

Instead of logging in automatically or being prompted to enter domain credentials, the kiosk PCs are instead prompted to enter a Microsoft account email or phone number, with no option to log in with a different type of account.

I thought a solution may lie in the "LastLoggedOnProvider" registry value under the "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI" key, but so far I've been unsuccessful in that troubleshooting route.

Has anyone seen anything like this before?
Avatar of kenfcamp
kenfcamp
Flag of United States of America image

In my experience with windows 10 installs/upgrades using local / domain logins, the easiest option is to temporarily disable the network connection until the initial login is configured and established.

By default if Windows 10 detects a network it will try to force a "Microsoft Account" login
Is that tool using the normai autoadminlogon entries in the registry?  If so is it worth exporting, clearing and putting back the keys after the process?

Steve
What happens when you disable auto-logon before running the upgrade steps?
reg add "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v AutoAdminLogon  /t  REG_SZ /d "0" /f

Open in new window

Here, it just works.

Win7 pro, domain joined, with a local user created and setup for autologon using sysinternals' autologon.exe, upgraded to win10 pro 1903. All that happens is that autologon will no longer work and needs to be setup again, but I can logon with the local test user without anything done in between but the in-place upgrade.
Avatar of supportmail

ASKER

What happens when you disable auto-logon before running the upgrade steps?
reg add "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v AutoAdminLogon  /t  REG_SZ /d "0" /f

Open in new window


I'm exploring this now. Setting this REG value manually before the upgrade was initially successful, though I'm not seeing consistent results running this as a command in the SCCM task sequence.
Since it works for me (see above), I suspect this could be due to an old setup at your end - what version is your setup?
Since it works for me (see above), I suspect this could be due to an old setup at your end - what version is your setup?

If you're referring to the Windows 10 OS setup, it's v1903 serviced through SCCM with updates through December (10.0.18362.535).
As current as it could be, ok. That IS strange. Please install a clean Win7 SP1 just as I did, setup autologon and use a standard 1903 and you will see that it just works. I wonder what your image might have implanted.
ASKER CERTIFIED SOLUTION
Avatar of supportmail
supportmail
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
That's what I suggested ...
and me!