SSIS Visual Studio 2019: ODBC Connection Immediately Throwing a VS_NEEDNEWMETADATA Error

infotechelg
infotechelg used Ask the Experts™
on
I have scoured experts exchange and all the other posts related to the failed validation and returned validation status "VS_NEEDSNEWMETADATA" error in Visual Studio 2019 and nothing I found applies to me.

I have an SSIS project that has two SSIS packages in them. Both use the same ODBC connection. Both are querying smiliar views from the same database. These views aren't changing (aka: the columns in the view are, and have been, static).

One of the packages executes fine. The other gives me the VS_NEEDNEWMETADATA error.

I've tired everything suggested in other posts to no avail. I've even completely deleted the Data Flow task and recreated it.

This is not an issue with OLE DB, but I don't want to use OLE DB.

Is there anything else I can try?

I did see in another post that this was only  happening to them on VS2019 and not 2017. Does anyone have any info on that?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Enterprise Business Process Architect
Commented:
32- or 64-bit or does it seem to matter?
Have you tried the kludge of setting ValidateExternalMetaData to False in the dataflow task?
Have you ensure both the 32-bit and 64-bit ODBC stacks have the same configuration?

Author

Commented:
I'll try these things. Thanks, Darrell.

Author

Commented:
I should add, this is happening locally (as well as after it's deployed). All packages are in various projects in Visual Studio, but in the same solution. They all will be running at the same BIT rate. So, provided that one of the packages is running fine with ODBC, but another is not, I don't think bit has anything to do with this.

But it did.

For the offending SSIS package, changing ValidateExternalMetaData to "False" worked. Though, what's weird is that the other package that works fine has that value set to "True". Any ideas as to why this needed to be changed to "False" for one package but not the other while using the same ODBC connection?

However, while I say "worked", I mean that the package actually ran, but then I got about 30 of these errors: Numeric value out of range. Which doesn't make much sense give that a) this error doesn't exist when I'm doing OLE DB, and b) Most of the values aren't numeric. I would think since like 3 of the fields are numeric, I would have received only 3 errors.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial