We help IT Professionals succeed at work.

Copy HTML to Word does not display the pictures

Copy HTML to Word does not display the pictures



I am copying HTML page to MS Word 2013, but the picture location shows just the frame
Thank you


h
the settings on Word :
w
Comment
Watch Question

Tom CieslikIT Engineer
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
Try not copy but right click on html file and select Open With - Microsoft Word

Capture.JPG
John KorchokProduction Manager
CERTIFIED EXPERT

Commented:
Does this happen on every Word page from every web site, or just in a particular Word file, or just from a particular web site?

Author

Commented:
if I right click and select Copy Image and go to Word Select Paste /Paste Special then select Bitmap and click OK it will paste the Picture properly in Word.

But this way, I will have to copy paste the text and pictures separately...that 's too much of work if you have to do that  on many HTML Pages.
Scott FellDeveloper & EE Moderator
CERTIFIED EXPERT
Fellow
Most Valuable Expert 2013

Commented:
It is probably because the image in the html is set like

<img src="images/image.jpg"> instead of <img src="https://mysite.com/images/image.jpg">

What are you trying to do by getting this to word? I use adobe acrobat to save web pages and it does a much better job. If you are trying to download and preserve web pages, try https://www.httrack.com/
Tom CieslikIT Engineer
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
If you want to get image from website you can also try save whole website as mhtml file.
Right click on browser and save as. Select mhtml extension and save somewhereon the disk.
This will create subcatalogs with pictures attached to this website.
You can go there and get pictures.

Remember that some websites are preventing to be copied so right click is disabled.

Another option is to run Mozilla Firefox, open website and select SOURCE to see.
In source code you can find link to picture so you can copy link and paste in separate window to see picture and then save on disk or use link to paste in picture properties in Word.

Author

Commented:
As I stated above:

if I right click and select Copy Image and go to Word Select Paste /Paste Special then select Bitmap and click OK it will paste the Picture properly in Word.

But this way, I will have to copy paste the text and pictures separately...that 's too much of work if you have to do that  on many HTML Pages.

So if it is done that manually, there should be a setting on Word that makes it as Default.
the bit map for the picture is not selected as Default, I had to select it manually each time I paste a picture.... How can I make it Default ??
Developer & EE Moderator
CERTIFIED EXPERT
Fellow
Most Valuable Expert 2013
Commented:
Which web page are you referring to?  I do think it has to do with the image being presented using absolute links.  If you try and copy and paste from your original question you posted here, it works as expected with the images coming through.  The reason is the images are not relative links.
<img alt="w" src="https://filedb.experts-exchange.com/incoming/2020/01_w02/800_1440542/word.JPG" class="file-block" style="max-width: 800px;">

Open in new window


If the image was embed relatively, I don't think it will work
<img alt="w" src="incoming/2020/01_w02/800_1440542/word.JPG" class="file-block" style="max-width: 800px;">

Open in new window


With that particular website, you may be stuck using the workflow you are describing. That is why I am suggesting an alternative workflow such as acrobat or something else to automate.

Author

Commented:
Thank you Guys,
Will get back to this topic sometime in the future

Explore More ContentExplore courses, solutions, and other research materials related to this topic.