We help IT Professionals succeed at work.

Renaming Exchange 2010 Public Folder for Exchange 2016 Migration

Aminrah
Aminrah used Ask the Experts™
on
I am currently in Coexistence mode with exchange 2010 and 2016.  I have moved all the account to 2016 and using ProxyPF Database to access Public Folders(PF) on 2010 which is working great.  I am now in the process migrating the Public Folders to 2016, but I am stuck on rename the folder that are not using the correct naming convention.

I run the Powershell, get the results below and I try to manually replace the (/) with (|)in the PF Management Console and get the error below. It allowed me to change one, but the rest gets the error below.  I also tried using Microsoft’s renaming Powershell, but that also errors out.  Help!  See details below:


[PS] C:\Windows\system32>Get-PublicFolderStatistics -ResultSize Unlimited | Where {($_.Name -like "*\*")


Name     : EX:/O=FIRST ORGANIZATION/OU=EXTERNAL (FYDIBOHF25SPDLT)
Identity : 000000001A447390AA6611CD9BC800AA002FC45A03002C6F1DA49BED0242A62635D4C628DA420000000004160000

Name     : EX:/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)
Identity : 000000001A447390AA6611CD9BC800AA002FC45A0300A793B4348B1AE141963773304B1509810000000000070000

Name     : EX:/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)
Identity : 000000001A447390AA6611CD9BC800AA002FC45A0300A793B4348B1AE141963773304B1509810000000000080000

Name     : EX:/o=First Organization/ou=First Administrative Group
Identity : 000000001A447390AA6611CD9BC800AA002FC45A030028145A632D428144AF3123AE27E751770000000000070000

Name     : EX:/o=First Organization/ou=First Administrative Group
Identity : 000000001A447390AA6611CD9BC800AA002FC45A030028145A632D428144AF3123AE27E751770000000000080000

Name     : /o=First Organization/cn=addrlists/cn=oabs/cn=Default Offline Address List
Identity : 000000001A447390AA6611CD9BC800AA002FC45A0300122EE0C8F702D44092BDC6F0DE5185E60000000000080000

 

MANUAL EDIT
--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
The following error(s) occurred while saving changes:

Set-PublicFolder
Failed
Error:
Cannot save the object '\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=First Organization/ou=First Administrative Group'. Make sure that you specified the correct Identity and that you have the necessary permissions to save it.

An error occured when setting the properties on object '\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=First Organization/ou=First Administrative Group'. Total 1 problem(s).
     Property Tag: DisplayName, Property Type: String, Error Code: -2147024891



I tried using the Microsoft instruction to rename the file and this is what I get:


[PS] C:\Windows\system32>Set-PublicFolder -Identity 000000001A447390AA6611CD9BC800AA002FC45A0300A793B4348B1AE141963773304B15098100
00000000070000 -Name EX:|o=First Organization|ou=Exchange Administrative Group (FYDIBOHF23SPDLT)

The term 'o=First' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of t
he name, or if a path was included, verify that the path is correct and try again.
At line:1 char:138
+ Set-PublicFolder -Identity 000000001A447390AA6611CD9BC800AA002FC45A0300A793B4348B1AE141963773304B1509810000000000070000 -Name E
X:|o=First <<<<  Organization|ou=Exchange Administrative Group (FYDIBOHF23SPDLT)
    + CategoryInfo          : ObjectNotFound: (o=First:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

[PS] C:\Windows\system32>
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Raheman M. AbdulMessaging and Directory Services

Commented:
Try with single quotes:  whole command in one line
Set-PublicFolder -Identity '000000001A447390AA6611CD9BC800AA002FC45A0300A793B4348B1AE141963773304B1509810000000000070000' -Name 'EX:|o=First Organization|ou=Exchange Administrative Group (FYDIBOHF23SPDLT)'

Open in new window

Author

Commented:
I added my account as "owner" to the folders and When I do as you suggest, this is what I get as an error now.


[PS] C:\Windows\system32>Set-PublicFolder -Identity '000000001A447390AA6611CD9BC800AA002FC45A0300A793B4348B1AE141963773304B1509810
000000000070000' -Name 'EX:|o=First Organization|ou=Exchange Administrative Group (FYDIBOHF23SPDLT)'
Cannot save the object '\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)'.
 
Make sure that you specified the correct Identity and that you have the necessary permissions to save it.
    + CategoryInfo          : NotSpecified: (0:Int32) [Set-PublicFolder], MapiOperationException
    + FullyQualifiedErrorId : 478C190D,Microsoft.Exchange.Management.MapiTasks.SetPublicFolder

[PS] C:\Windows\system32>
Commented:
I after extensive research, I found out that exchange 2016 does not use "System Public Folders" so there is no need to correct the names.  You may save yourself a lot of time and worry by manually removing spaces in Alias' and  disabling mail-enabled  public folders before the migration.  Just make a list of the mail enabled folders and enable them in 2016 after the migration, it is very trivial.
My situation is On Prem and a single domain.

Thanks