We help IT Professionals succeed at work.

Windows 10 Kiosk Mode - Microsoft Edge cannot add network printers

I'm deploying Windows 10 Kiosk Mode - Microsoft Edge with "As a public browser" manually by using Windows Settings (https://docs.microsoft.com/en-us/microsoft-edge/deploy/microsoft-edge-kiosk-mode-deploy)

So that mean, Windows creates a normal local user is named "KioskUser0" by default and automatically login and start Microsoft Edge with defined websites.

It works fine with local printer (USB port) and problem happen with network printers. I don't know how to add network printer to this user (KioskUser0). I have been trying to Google without luck (these days).
Comment
Watch Question

Distinguished Expert 2019

Commented:
Please try this: undo the kiosk setting, logon as that user, install that networked printer and then re-apply the kiosk settings and see if the printer shows up.
IT Managed Service
Commented:
Thank you for your support. Finally, I found out the solution after few days with bundle of trying (registry, GPO...). I add network printer by "Local Port", then it appears by default on all users.
P/s: You cannot login locally Kiosk user as it is managed by Windows OS.

Install a local printer driver in Windows 10

1. Click on the Start button, then click on Settings.
2. Click on Devices.
3. Select Printers & scanners in the menu on the left.
4. Click Add a printer or scanner.
5. Click on The printer that I want isn't listed link.
6. Mark the Add a printer using TCP/IP address or hostname, and click Next.
7. In the Device type drop down, select TCP/IP Device.
8. Type in the IP address of the printer in the Hostname or IP address field, and click Next.
9. Make sure the Query the printer and automatically select the driver to use is checked, and then click the Next button.

If you get a version conflict message asking which version of the driver to use, select the Use the driver that is currently installed (recommended), unless the local printer is being installed to test a different version of the drivers.  You will need to know the location of the test printer drivers.
Distinguished Expert 2019

Commented:

" P/s: You cannot login locally Kiosk user as it is managed by Windows OS." - as I said: UNDO the kiosk mode, then logon and install that printer and reapply the kiosk mode. Please retry and see whether that would have worked as well.

Thành Huỳnh QuangIT Managed Service

Author

Commented:
HI @McKnife,

As I mentioned, Windows creates and manages Kiosk users (Yes, you could find SID of this account in Windows registry, but you cannot use this account to login normally), then there are no way to UNDO the Kiosk mode and login these accounts :D as I had already tried before posting this question ;)
Distinguished Expert 2019

Commented:

Then we are talking about different things.


I am talking about "assigned access", as mentioned in all kiosk mode articles.

I can define assigned access for any account myself and I can undo it at any time.

Thành Huỳnh QuangIT Managed Service

Author

Commented:
Hi McKnife,

Thank you for sharing. I've just worked on Kiosk Mode for short time, then may not fully understand some points.
Distinguished Expert 2019

Commented:

It's very easy:

1 create a test user account "test", logon as test and set a default printer, then logoff

2 as administrator, open an elevated powershell and run

Set-AssignedAccess -UserName test -AUMID Microsoft.MicrosoftEdge_8wekyb3d8bbwe!MicrosoftEdge

3 logon as user test

Only edge will start, then.