We help IT Professionals succeed at work.

TP-Link Archer c5400 will intermittently hand allow cascaded router DHCP to pass through.

Low Priority
85 Views
Last Modified: 2020-01-30
Went on a call to a new client today, who has been having issues with their network.  They have a DSL modem with WiFi on channel 1 (Since disabled) cascading to a TP-LINK Archer c5400 (Upgraded firmware today).  They are working on getting the PPPoE (Centurylink DSL connection) so we can bridge the DSL modem and set the router up properly.  Some devices hardwired and wireless will not function because they are getting a DHCP address from the DSL modem.  I can log into the DSL modem on those computers.  Is this a malfunction in the TP-Link (It only happens less than 10% of the time and very random on devices)?  I have had very bad experiences with TP-Link switches, are their routers any better?  The owner said the problems have always been existant and the old IT company (who installed it), could never get it working 100%.  I am recommending replacement of router, but wanted to hear thoughts on this subject.  The client will be ordering their own new router, and won't have until Monday.  This should be a non-issue once the modem is bridged.

If I release the DHCP enough times, it will go back to the correct DHCP server of the router and start working properly.  The DSL modem is not accessible by devices connected when getting the working IP address.
Comment
Watch Question

Paul MacDonaldDirector, Information Systems
CERTIFIED EXPERT

Commented:
Um...turn off the DHCP capability in the DSL modem?  

I'm guessing the DSL modem is not used as the "Internet" connection on the back of the  TP-LINK Archer C5400.  Regardless, if clients are getting DHCP responses from the DSL modem it's hard to see how it would be the Archer's fault.
Jason JohanknechtIT Manager

Author

Commented:
You should never have 2 DHCP servers in the same subnet, as they will alternate handing out IP addresses.  I don't recommend cascade setup for anyone, and haven't seen one in years.  That said, yes I can turn off the DSL DHCP, but why is the TP-Link passing that information through?  Again remember I will be making changes come Monday to resolve the problem permanently.  I am looking only for thoughts on the TP-Link router and is reliability and functionality.  I have never seen a cascaded router hand out the IP address from first router.  People use to do this as work around to create a guest network before guest networks existed in routers and access points.  It's been a long time since I have seen anyone do this, and I would say 100% it was done by someone that lacks any IT knowledge in todays world.  The TP-Link is capable of guest networks.  The new client doesn't want any changes made until Monday, so this thread is strictly a thought dump.
Jason JohanknechtIT Manager

Author

Commented:
I forgot to mention it is connected via the WAN port to the DSL modem.  Wan config is Dynamic connection.
Director, Information Systems
CERTIFIED EXPERT
Commented:
"That said, yes I can turn off the DSL DHCP, but why is the TP-Link passing that information through?"
I'd guess the TP-Link is configured for DHCP passthrough/forwarding, either explicitly or through some default setting.  In either case, the client just sends a broadcast message asking a DHCP server to answer and it would appear the DSL modem is beating the TP-Link to respond.  I suppose you could look to see if DHCP passthrough/forwarding is an option you can turn off in the TP-Link.

"Again remember I will be making changes come Monday to resolve the problem permanently."
Maybe not, if the clients can still get a DHCP response from the DSL modem!
Jason JohanknechtIT Manager

Author

Commented:
Could not find anything about the passthrough.  
The DSL will be in bridge mode with no DHCP server running when I install things correctly on Monday.  The client does have the PPPoE information now, but would prefer to wait until Monday.  They have an important day Saturday.
Paul MacDonaldDirector, Information Systems
CERTIFIED EXPERT

Commented:
I'm certain the problem will go away once the DSL modem stops offering DHCP.  Best of luck!
Paul MacDonaldDirector, Information Systems
CERTIFIED EXPERT

Commented:
Jason Johanknecht requested that this question be deleted on 2/3/2020 for the following reason:

No information regarding any specific setting in the TP-Link was obtained, which was the reason for the question.  The question was not how to solve a problem with DSL and cascaded DHCP.  We see this setup many times a year, and is an easy by bridging the DSL modem.

To cancel this request, state your reason as a comment and click the 'Object' button.

Actually, the two questions asked were:
     "Is this a malfunction in the TP-Link (It only happens less than 10% of the time and very random on devices)?  "
...and...
     "I have had very bad experiences with TP-Link switches, are their routers any better?"

The answer regarding this problem being "a malfunction in the TP-Link" was addressed.  The OP may imply he knew the answer already, but this was the question he asked.

The second question was ancillary to the first and, while not directly answered, it's not difficult to presume the OP's frustration with the brand to be based on experiences like this one, which are solvable.  In other words, the second question was answered indirectly by clarifying that the problem wasn't in the router to begin with.

I don't particularly care about the points here, but the closing comment is disingenuous, implying the OP did not get the help he asked for.  The solutions provided would almost certainly fix the problem the OP reported.
Jason JohanknechtIT Manager

Author

Commented:
Thanks for all your thoughts on this subject.  While I did not find the passthrough setting, this information is probably helpful to the next person down the line.  For that reason I have selected it as the answer.  I wasted your valuable time with a dumb question I didn't really care about, and you put a lot of effort into the answers.  I do appreciate the effort.  Again, I shouldn't have even posted this question since I knew the solution before hand.