We help IT Professionals succeed at work.

Clear any reference to old router on wireless network for printer set up

Wilf asked
I have a remote network that consists of 4 Windows 10 workstations [3 at 1909, and one at 1809].  They have recently changed ISP providers,  and all 4 workstations have connected to the new router wireless.  The issue is with a printer.  It is a Canon MF733CDW.  It is connected to the router, and two of the computers are connected and and working normally.

The other two computers will not connect and print with a wireless connection.  When I run the Canon install file, the Canon software cannot find the printer even when I put the printer IP address in.  I can log onto the printer with the one workstation via the printer web page, and all looks normal.  When I try connect the printer via Windows 10, Windows 10 finds the printer and installs it, but the test page will not print.  It sits in the queue forever, but does not print.  I have tried sharing the printer from one of the workstations that does print.  The workstation finds the printer, but again will not print a test page.

I have reset the network adapter from within Windows 10 with the same results.

I suspect there is some confusion in the workstation because of the change of routers, but have not found a method to clear any remainder of the old router connections.  I am leary to do a winsock reset, as I will probably loose the connection.
Watch Question

Distinguished Expert 2019

Check the two computers that are not working on whether Windows or the wireless adapter's tool to manage network connections.

Intel wireless management tool in particular does not merely trust the network ssid and the phrase to access a wireless network.

This is a security feature to avoid a "fake, mimicking" hijacking of a wireless client.


Windows is managing the connections.  One is a Lenovo laptop with its internal  wireless adapter, and the other is a desktop with a TP-Link adapter that is managed by Windows
Distinguished Expert 2019
are they successfully connecting to the wireless network? can they see the other computers on the wireless network?
try doing an arp -a ping the router gateway and then arp -d to clear the arp table to see whether they can.

since the other computers have no issues with accessing the printer over the network, it looks as the issue is possibly with the two systems and whether they are somehow bound to a wireless gateway that has no path to the printer.
ping the printer ip is it pingalbe from the working system but not from these ones?

another on the systems where it is not working, forget (delete the known network) and reconnect to see whether it is now able.

The other consideration is to look at how the printer properties, port is defined on the computers that do not work as compared to the ones that do.
If the ones that do not work, reference a specific IP of the canon printer, the issue is likely that the IP changed between the old and the new while the two that do work, use a special canon reference to the printer in the port setting when the canon software was used to install the printer and configure it.

i.e. on the working, the port points to as an example canonmodelnumber while on the two that do not work, it points at a tcp/ip x.y.z.a and the printer currently does not have that IP.
In this case, you have a simpler option, login into the router where the printer's connection is reflected and configure it with an IP reservation to get the IP x.y.z.a
it may refresh right away or might require that you restart the printer at which it will come back with the x.y.z.a IP and at this point all your computers will start printing (prior to proceeding, check to make sure the two computers do not have many prints queued up or all will be printed. You could cancel some, duplicates or all .......)


Thank you for the information.  It appears the two problem computers have been turned off for the weekend, so I will get to try these suggestions on Monday.


I used the reset the network adapter twice on each of the non connecting computers and was finally able to install the Canon printer.  It would appear to be a leftover from the previous router.

The printer port on all is named CanonMFC