Link to home
Start Free TrialLog in
Avatar of Mark Litin
Mark LitinFlag for United States of America

asked on

After replacing drive in an iMac 21" late 2014, the display has vertical lines

After replacing the drive with an SSD in an iMac 21" late 2014, when resetting the display and booting, vertical lines appeared on the display which remained once booted. One is about 1/3 inch black line and on very thin green line.  I've replaced the video cable with no change.

I used a triangular plastic prying tool to cut through the adhesive according to the instructions, careful to avoid slicing too far and disturbing the display and used anti-static precautions. When I removed the display, I noted that there was no seal broken on the inside of the display.  But when reinstalling the display, the lines appeared.

I'm perplexed on why this has happened and would really like to repair the display if possible.  

I wonder if anyone has any insights about this I would be most grateful as it;'s become a financial and time sinkhole.


Thanks!
ASKER CERTIFIED SOLUTION
Avatar of Dr. Klahn
Dr. Klahn

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Mark Litin

ASKER

Thanks. I'll try this.  This confirms the info I've gathered.  2 displays gone due to this very fragile display.  It would seem that since the display is connected by adhesive tape that even if it had been separated with a slicing tool that it would be expected that some pulling would be required due to residual hold.  Disasteraly poor product design.
Replaced the display.  Thanks!