We help IT Professionals succeed at work.

Cannot access some pages using MS Edge Version 80.0.361.45 (Official build) beta (64-bit)

I am running the dev beta version of Microsoft Edge. Recently I started not being able to access some pages.  Others I can access.  It seems that most of the pages I cannot access require authentication.  I understand there may be issues with the beta and dev version but I want to know if anyone else has seen this issue and knows the resolution?   Uninstall and install a more stable version? Apply a KB fix? I included the error page.

hmm.png
Comment
Watch Question

Abdul Jalil Abou AlzahabConfiguration Manager & Windows 10 Administrator

Commented:

Why you are not installing the final version of Microsoft Edge ?
Kidney find the below link to download:

https://www.microsoft.com/en-us/edge?form=MY01BV&OCID=MY01BV

Christopher Gore , MBAEnterprise Solutions Architect

Author

Commented:

The beta version I have is a developers' version. It updates every week and is newer than the Final Release.  The latest update was 1/31/2020.

Bill PrewTest your restores, not your backups...
Expert of the Year 2019
Top Expert 2016

Commented:
I have been using the non-beta version here since it became available, and haven't gotten very many of those type errors.  Some things I have seen blocked are usually due to my router, which I recently upgraded and now includes Intrusion Protection.

Are any of the sights you are seeing this on public sites that you could share a link too, I'd be happy to try it here and see if I also get that message.


»bp
Christopher Gore , MBAEnterprise Solutions Architect

Author

Commented:

See if you get prompted to log in to this site or get the "Hmm... can't reach this page"

www.ultimatix.net


Thanks


Christopher Gore , MBAEnterprise Solutions Architect

Author

Commented:

I reinstalled the release version, and I get the same results.

Bill PrewTest your restores, not your backups...
Expert of the Year 2019
Top Expert 2016

Commented:
It errors out, with a timeout "ERR_CONNECTION_TIMED_OUT".

But I get the same result in Chrome or Firefox also...


»bp
Christopher Gore , MBAEnterprise Solutions Architect

Author

Commented:

It's interesting because I can access that page and others that give the same error in Internet Explorer.

Test your restores, not your backups...
Expert of the Year 2019
Top Expert 2016
Commented:

Seems to be something odd going on with that site.  The first time I tried it in IE it took a little time, then brought me to a Bing search for the URL.  I clicked on the first match there, which was the website, and it ended me up at an "auth.ultimatix.net" page.


I copied that new URL into Edge and it brought up the login page.  Now when I try to get to "www.ultimatix.net" in Edge it goes right to the auth page.


Seems to me like some cookies or other objects get stored in the browser that then allow it to work.  So that site seems to not handle those objects missing properly.


That's about all the debugging I have time for right now, but the fact that IE performs differently than the other browsers makes me think it's a "bug" in IE that makes the "bug" on their site work...



Christopher Gore , MBAEnterprise Solutions Architect

Author

Commented:

I was also able to get to the site via "auth.ultimatix.net" and "https://www.ultimatix.net". One other issue is when I do sign in, it makes me authenticate twice. It is not supposed to do that. Other browsers do not cause that issue.  When looking with Developer Tools, it seems that something is going on with the cookies.  I'm awarding @Bill Prew the answer, but additional information might be of value if there is a followup on the double authentication part.