We help IT Professionals succeed at work.

Need help with my Cisco 2821 configuration

Joel_Sisko
Joel_Sisko asked
on
Hey everyone - I am trying to get my router up and running and having a slight issue getting it to connect the internet ( to the ISP ). My basic idea is connecting G0/0 going out to the ISP (Wan), G0/1 to my server. I know im missing something. I've included my running config.
Any help would be appreciated!!

Current configuration : 1735 bytes
!
! Last configuration change at 16:01:56 GMT Tue Jan 21 2020 by admin
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Core_Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
clock timezone GMT -8 0
!
dot11 syslog
ip source-route
!
!
ip cef
!
ip dhcp excluded-address 10.24.1.1 10.24.1.10
!
ip dhcp pool core
 import all
 network 10.24.1.0 255.255.255.0
!
!
ip domain name xxxx.net
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2821 sn FTX1311A0C3
username admin privilege 15
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 description PrimaryWANDesc_
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 10.24.1.1 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 no ip address
!
interface FastEthernet0/1/1
 no ip address
!
interface FastEthernet0/1/2
 no ip address
!
interface FastEthernet0/1/3
 no ip address
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
ip nat inside source list nat-list interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
!
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp profile default
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
 transport input all
!
scheduler allocate 20000 1000
 
end
Comment
Watch Question

Network Security Engineer
Distinguished Expert 2018
Commented:
Hi there,

few things are missing.

1- DHCP pool is not completed

Here is a sample for you

ip dhcp pool USERS
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server 8.8.8.8 1.1.1.1
   domain-name Cybecomp.local
   lease 5 1 1


On this line

interface GigabitEthernet0/1
 ip address 10.24.1.1 255.255.255.0
ip nat outside ---- Remove this -- no ip nat outside. Then add --ip nat inside--
 ip virtual-reassembly in
 duplex auto
 speed auto

You did not create an access list to nat the traffic, do this.

access-list 1 permit 10.24.1.0 0.0.0.255

then add this.

ip nat inside source list 1 interface gi0/0 overload.

That should give you internet.

Author

Commented:
Thank you... the solution was spot on!!

Author

Commented:
Now going further...with G0/0 set to dhcp & G0/1 dhcp pool of 10.24.1.0 if I set my FastEthernet ports to use the dhcp pool do I also set a Vlan1 to an ip address?
Hemil AquinoNetwork Security Engineer
Distinguished Expert 2018
Commented:
by default once you have the network created the vlan would know what DHCP to take. you do not need to assign any vlan. just refer my DHCP configuration above.

Author

Commented:
Hemil - thank you once again!!