Avatar of webiis
webiis
 asked on

switched to office 365 and now I keep getting prompted for a password to connect to my exchange server

switched to office 365 and now I keep getting prompted for a password to connect to my exchange server.
I tried going to credential manager and deleting the entry, and have verified that autodiscover can be resolved by nslookup and is working properly.
Microsoft OfficeExchangeMicrosoft 365

Avatar of undefined
Last Comment
Saif Shaikh

8/22/2022 - Mon
Saif Shaikh

This is expected behaviour.


If all mailboxes are migrated from onpremise exchange server you need to disable autodiscover on exchange server.


Try to set Set-ClientAccessServer –Identity “CASxx” –AutoDiscoverServiceInternalUri $NULL  

By running these steps/commands, you are essentially removing the on-premises information with regard to Autodiscover; thus eliminating the conflict that your end users are experiencing between the O365 autodiscover and the on-premises one.


webiis

ASKER
We only use office 365 for the office app. We still connect to our Exchange 2016 server.  It's weird. It looks in at first and then it prompts for pw and never accepts the correct password while it's says connected to exchange server. The volume license version of office never had this  problem. The problem started after moving to office outlook 365. The  server will remain. They want their own exchange server. It's 2016 and fully patched and licensed.
Saif Shaikh

What is the outlook version is it 


Outlook 2016 plain


OR


Office 2016 for Office 365 business - If it is this then it will connect directly to office 365 mailbox 

https://www.gothamweb.com/portal/index.php/knowledgebase/8/Outlook-bypasses-AutoDiscover-and-connects-directly-to-Office-365-mailbox.html


Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
Saif Shaikh

Office 2016 for Office 365 business - If it is this then it will connect directly to office 365 mailbox


Then you need to add registry key.


HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\office\16.0\outlook\autodiscover DWORD: ExcludeExplicitO365Endpoint Value = 1

Open in new window


Then restart your computer and it should stop trying to connect to Office 365.

webiis

ASKER
Office 2016 for Office 365 business
Saif Shaikh

Starting in Outlook 2016 version 16.0.6741.2017, Microsoft has enabled a new feature called Direct Connect to Office 365. If you have exchange server and this client  Office 2016 for Office 365 business is designed to connect directly to O365 then you need to add the registry key.


HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\office\16.0\outlook\autodiscover
DWORD: ExcludeExplicitO365Endpoint
Value = 1

Then restart your computer and it should stop trying to connect to Office 365.



⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
webiis

ASKER
I can get up to this far: HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft

There is no outlook key under Microsoft.
Saif Shaikh

You are looking wrong information. Look for  office and not outlook.


You need to look for outlook only after  \office\16.0\outlook\autodiscover

webiis

ASKER
Please see the screenshot attached.
outlook-fix.png
Your help has saved me hundreds of hours of internet surfing.
fblack61
webiis

ASKER
Did you get the attachment?
ASKER CERTIFIED SOLUTION
Saif Shaikh

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.