We help IT Professionals succeed at work.

How to move configuration of Cisco Port to another

Hey all,

So I was asked to do something out of my realm and was wondering if someone could easily explain this to me.  Later I will be moving an access point from 1 location in someones office to another location, its basically unplugging it from 1 patch panel and installing it in another, however the trick is I need to move the configuration on the switch port to the new jack.   This is a Cisco POE switch.   Can someone tell me once I SSH/ Telnet into the switch how to move the port configuration then save it?  The new patch panel port would be A30 I dont know what the current patch number is but I have never done this before and do not want to mess anything up.   As always help is appreciated.
Comment
Watch Question

Hello ThereSystem Administrator
Distinguished Expert 2018

Commented:
1. Run on the current switch:
show running-config

Open in new window


2. Find the port where the AP is connected and copy all lines under the interface to txt. There should be something like this:
interface FastEthernet0/1
 description AccesPoint
 switchport access vlan 10
 switchport mode access
 etc

Open in new window


3. Telnet to the switch in the new location and run:
configure terminal
interface FastEthernet 0/1
...copy here the configuration you saved
end
write

Open in new window


Be sure to use the correct VLAN ID and correct interface ID.
Andrew N. KowtaloSupport Center Engineer

Author

Commented:

Is there anything specific I need to add to any of those lines?

Also what if both AP's are running off the same switch on 2 different ports?

Hello ThereSystem Administrator
Distinguished Expert 2018

Commented:
If the VLAN ID is the same, you just need to copy the configuration. And if you want to use a different port, just change the interface ID to the desired interface ID.

configure terminal - you enter the configuration mode
interface FastEthernet 0/1 - you enter the interface (interface FastEthernet 0/10, interface FastEthernet 0/22, interface GigabitEthernet1/0/10, etc.)
...copy here the configuration you saved
end - you go back to enable mode
write - you save the configuration

Open in new window


You can list the status of interfaces: show interfaces status
Andrew N. KowtaloSupport Center Engineer

Author

Commented:

Appreciate this, I am not a Cisco Switch guy so assume I know 0 about switch port  configurations thats why I was asking if I could just get the exact commands and cut and paste the strings into the command line :) 

Hello ThereSystem Administrator
Distinguished Expert 2018

Commented:
A little example...
sw-example.PNG
Andrew N. KowtaloSupport Center Engineer

Author

Commented:

I do not know what I am reading there is that getting the configuration or is that the post copy command to the new port?

Hello ThereSystem Administrator
Distinguished Expert 2018

Commented:
This is how to configure a new port.
Andrew N. KowtaloSupport Center Engineer

Author

Commented:

ok so Just say the port its on right now is A15 and I need to move it to A30.  I can unplug the AP from AP and plug it into A30 after I verify A30 on the switch is active.  Once I do that I can log into the switch and just run those commands and I am good?

Hello ThereSystem Administrator
Distinguished Expert 2018

Commented:
Moving the AP is the last step. First, you need to preconfigure the port.

1. Get the configuration from the current interface
2. Copy the configuration to the new interface
3. Move the AP

Btw to avoid any misunderstanding, Cisco switch interfaces are named as FastEthernet, GigabitEthernet... Why do you call them A15, A30?
Andrew N. KowtaloSupport Center Engineer

Author

Commented:

A15 and A30 are the names of the patch panel jacks on the wall.   Sorry for the confusion.   I need to trace the wire from A30 on the patch panel and plug into that port on the switch to see if its active.  Once that is done I can move the ports.   I will be onsite at the client today from 1pm est to 5pm est.   

Hello There has given you good advice re: configuring switches.  
But, after reading all this, I'm wondering if that's what's needed?

Let's start with my perception of the situation.  This may be a good way to clear up any misunderstandings:

You have a site that has an active Access Point.
The Access Point plugs into a patch panel somewhere in the building.
You are going to move the Access Point.
This will entail:
- unplugging the access point from the patch panel
- moving the access point to its new location.
- plugging the access point into a *different* patch panel that's available.
But, before you do the last step, you need to assure that the patch panel port isn't already in use for something else.
And, you will want to make it ready for use for the access point.
Right?

Presumably, you have a diagram or table or .... something that will tell you how the patch panel  ports terminate in the central "switch room" or whatever they call the place where the internet feed is located.  Something like that, eh?

The first thing I would be thinking of doing would be this:
Find where the original patch panel port terminates in the switch room.  I'm thinking it will be another patch pane portl.  It could be a switch port.

If it terminates at a patch panel port then there will be a cable in that patch panel port going somewhere in the switch room.
In that case, the only thing you need to do is move that cable from the original incoming patch panel port to the new incoming patch panel port in the switch room that corresponds to the new connection at the other end of the building cabling - to reach the access point in its new location.

In the latter case, you would leave the cable plugged into the switch port and move the other end of it from one patch panel port (the original) to another patch panel port (the new one).  

If this is correct, the switch need not be reconfigured.
Andrew N. KowtaloSupport Center Engineer

Author

Commented:

Thanks was told A30 is the port that has no connection and where the AP would be going to get plugged into.  I can just trace the wire from A30 to the switch and make sure the port is active.  Once that is done I can copy the config to that port then move the ap there.  

Andrew N. KowtaloSupport Center Engineer

Author

Commented:

I am going to leave this open until I am done in case I have any questions.

I'm really confused by your description.
I had imagined that the access point work was somewhere else in the building and it was going to be physically moved - thus ending up on another cable that comes back into the switch room terminating at another patch panel port.
For clarity, we need a diagram like this:

FROM:
Switch Port #XX <> Patch panel port A15 <> Original distant Ethernet port <> Access point.

TO:
Switch Port #XX <> Patch panel port A30 <> New distant Ethernet port <> Access point.
[by moving the cable at switch port #XX from A15 to A30}
Presumably, port A15 on the patch panel goes out into the building and only has the access point on it; and, no downstream switches.

OR TO:
Switch Port #YY <> Patch panel port A30 <> New distant Ethernet port <> Access point.
[Assumes that A30 is already wired to switch port #YY.  Leaves switch room cables alone and reconfigures function of switch port #YY]
Presumably, patch panel port A30 isn't really "unused" but is wired to the new Access point location already.
Andrew N. KowtaloSupport Center Engineer

Author

Commented:

OK Port 1a33 is plugged into port 22 on the poe switch

Port 1a40 is plugged into port 30 on the poe switch

port 1a41 is in port 34 of the switch.


AP is currently plugged into 1a33 I need to move it to 1a40.   Both have internet access.   I just need to copy the settings from 1a33 to 1a40 for trunking purposes because there is guest network.   There are 3 switches in total none labeled with an IP so I am assuming they are in order of IP .15 .16 .17 I am going to try .15

Andrew N. KowtaloSupport Center Engineer

Author

Commented:

I can't tell if this is the AP

interface GigabitEthernet1/0/22
 description 1C-34
 spanning-tree portfast


interface GigabitEthernet1/0/30
 description 1C-13 Student
 spanning-tree portfast


I dont think so...


Andrew N. KowtaloSupport Center Engineer

Author

Commented:

That has to be it. the .15 switch


interface GigabitEthernet1/0/22
 description 1A-33 BCAT-AP-Reception g0
 switchport mode trunk
 spanning-tree portfast

Andrew N. KowtaloSupport Center Engineer

Author

Commented:

So how do I integrate this with the config?  I need to set this on port 30.   Here is 30's current setup


interface GigabitEthernet1/0/30
 description 1A-40 CIO Office
 spanning-tree portfast


interface GigabitEthernet1/0/22
 description 1A-33 BCAT-AP-Reception g0
 switchport mode trunk
 spanning-tree portfast


configure terminal 

interface FastEthernet 0/1 

...copy here the configuration you saved 

end 

write

Andrew N. KowtaloSupport Center Engineer

Author

Commented:

A#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
BCAT-SW-A(config)#interface GigabitEthernet1/0/30
BCAT-SW-A(config-if)# description 1A-33 BCAT-AP-Reception g0
BCAT-SW-A(config-if)# switchport mode trunk
BCAT-SW-A(config-if)# spanning-tree portfast
BCAT-SW-A(config-if)#
BCAT-SW-A(config-if)#end
BCAT-SW-A#write
Building configuration...
[OK]
BCAT-SW-A#


I did it!! YAY!

Hello ThereSystem Administrator
Distinguished Expert 2018

Commented:
This should be easy. Enter the switch and type:
enable
configure terminal
interface GigabitEthernet1/0/30
description <your_description>
switchport mode trunk
end
write

Open in new window

Hello ThereSystem Administrator
Distinguished Expert 2018

Commented:
I was too late. :-)
Andrew N. KowtaloSupport Center Engineer

Author

Commented:

I am a little worried because the wifi is connected but it keeps saying no internet.  


Even though I do have internet I disconnect from it, and reconnect, it shows connected then goes to no connection.

Hello ThereSystem Administrator
Distinguished Expert 2018

Commented:
The access point might have more ports. Did you connect the cable to the correct one?
Support Center Engineer
Commented:

Hi yes I did.   I think what happened was when I plugged it in, it went through a full startup cycle and then rebooted after being on the new port.   So now I have 5 solid bars and a seriously good UL DL speed.

Hello ThereSystem Administrator
Distinguished Expert 2018
Commented:
Glad you got it working. Feel free to mark all helpful posts. :-)
Andrew N. KowtaloSupport Center Engineer

Author

Commented:

I did thank you! Very helpful!! I feel I got some Cisco Switch experience out of it! :) 

Hello ThereSystem Administrator
Distinguished Expert 2018

Commented:
:-)
Andrew N. KowtaloSupport Center Engineer

Author

Commented:

Well after all that I still can't get this friggin phone to connect.  Its an Iphone 8 plus.   Its showing 4 strong bars.  My phone and laptop are fully connected with full bars.   However no matter which SSID I connect to it says no internet connection from the wireless WTF. 


Anyone got any suggestions

Andrew N. KowtaloSupport Center Engineer

Author

Commented:

I went through every troubleshooting on this stupid thing.  Forgot network, reconnected to both guest and internet, reset network settings is there a fast SSID enable option?