Link to home
Start Free TrialLog in
Avatar of atsanders
atsandersFlag for United States of America

asked on

Installing Remote Desktop Services Role on Server 2019 Std. Error

Installing Remote Desktop Services Role on Server 2019 Std. Hyper-V Guest.
1. Role is installed via Remote Desktop Services installation --> Quick Start --> Session-Based Desktop Deployment.
2. Remote Desktop Services Role installation completes successfully
3. Session Collection installation failed with following error: "Failed: Unable to create the session collection. The property UserAuthenticationRequired is configured by using Group Policy Settings. Use the Group Policy Management Console to configure this property."  (Screen shot below)
4. I tried configuring the following Group Policy with same result:  Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Security\Require user authentication for remote connections by using Network Level Authentication: Enabled

User generated image
I'm not sure if this is correct GPO to modify. I'm at a loss. Any guidance would be much appreciated. Please let me know if you need additional information. Thanks! Chip
ASKER CERTIFIED SOLUTION
Avatar of Philip Elder
Philip Elder
Flag of Canada image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of atsanders

ASKER

Good morning Philip,
Thanks for taking time and detailed response. I made the NLA change as part of my initial troubleshooting steps. I changed GPO back to Not Configured. Unfortunately, receiving same error.

I should have stated in initial question, The DC is Windows 2019 Std.. DC was migrated from SBS 2011. I'm thinking a GPO from SBS 2011 may be causing error. However, I'm unable to locate a NLA object not set to Disabled.

Please let me know if you have additional thoughts & Thank you!
Hi Philip,
Update....   Issue resolved. I did find GPO from SBS 2011, (Windows SBS Client Policy) NLA "was" set to Disabled. Changed to Not Configured. All good. Thanks Very Much for assistance sir!
Chip