Avatar of chalie001
chalie001
 asked on

no network

no internat no gui after installing oracle linux
lnxusr43unx
LinuxVirtualizationLinux SecurityVMwareLinux Networking

Avatar of undefined
Last Comment
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

8/22/2022 - Mon
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

can you ping 8.8.8.8

Instructions for installing a GUI are here

https://support.oracle.com/knowledge/Oracle%20Linux%20and%20Virtualization/2153562_1.html
David Favor

Best to start with Oracle 8.1 as there are to many changes to enumerate.

Note: If you install Oracle server version there will never be a GUI, as there will rarely be a graphical device connected to a server version.

If you truly do have a graphical device connected to your server, then you'll install xserver-xorg then refer to your Distro's docs for how to get X11 working. Or easier, just install some Desktop + xserver-org will likely be installed + configured to work.

Note: Normally ifconfig lives in the net-tools package (on most Distros). If net-tools is missing then many other parts of the networking stack code may be missing also.

Start with Oracle 8.1 first, so you're not trying to work around some bug. If your networking is active, just install the net-tools package.
chalie001

ASKER
am geting lnx this linux is certified for software i what to install
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

okay well that proves there is no internet.

how did you setup the VM settings, NAT, Bridged, Host only ?

check if the VM gets an IP Address ?

check with

ip addr show

Open in new window

arnold

netstat -rn

According to your image you are bridging. Did you configure the IP 192.168.8...

What is the ip on your lan,check on .
netstat -rn

Question default route?

Gateway
chalie001

ASKER
hi am geting this
df
i did show the seting in first post
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
ASKER CERTIFIED SOLUTION
arnold

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
chalie001

ASKER
how do i edit
arnold

In your current state, you can bring up the info
sudo ifconfig enp0s3 up

To have connection brought up at boot.


Try, nano
Note, you need to either elevate your shell, sudo -i

If it is not installed use vi,
Use arrow keys to navigate to ONBOOT=no
While positioning the cursor on n, cw (change word) type yes
Hit escape key,
Hit  ::wq
This will write out/save the changes and quit vi.

This should fo it.
David Favor

Andrew brings up a good point. The entire net-tools framework is currently being deprecated.

This includes retiring ifconfig + also converting the entire network setup to the NetPlan project.

If you get output using the ip command then ifconfig shows to be missing, this is a very good indication that ifconfig has been completely retired from your Distro version.

Dig into your Distro docs about how your specific Distro is handling the entire net-tools + NetPlan change over.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
arnold

A slight sight, oracle as a restricted user often does not gave /sbin which is where ifconfig, in the path.
This is why it could not be located.

The likely issue, during setup when the ip was configured as static versus DHCP, the option to activate at boot was not selected; thus, onboot=no in the config.

sudo ifconfig -a
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

A default install of Oracle Linux, root or non-priv user, there is no ifconfig.

It's also a bit odd, that the defined networking is set to static ?

Have you set a STATIC configuration ? and not DHCP ?

it maybe quicker to re-deploy (re-instll) and for quickness, select DHCP....

where did you get the IP Address from ? and use a Default Networking of NAT in virtualbox.