Avatar of chalie001
chalie001
 asked on

error start ubuntu

error starting ubuntu vm
ubuntu
i did this before i restartvm
https://help.ubuntu.com/community/Oracle%20Instant%20Client
LinuxUbuntuShell Scripting

Avatar of undefined
Last Comment
skullnobrains

8/22/2022 - Mon
arnold

Look at /etc/profike or post it, it has a syntax error, an errand entry, mismatch.

Was it edited elsewhere and transferred?
cat -v /etc/profile

Look at adding \ before the ()
ASKER CERTIFIED SOLUTION
Samieullah Rana

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
David Favor

At least one problem is in your $PATH setting, as arnold + Samieullah both mention.

The question is the correct fix.

If you're directory actually contains (64), then you must escape the characters "()". Unlikely this is true.

More likely is the directory is named some other name, which contains no shell escape characters.

First determine the actual path name, then if you can't figure out how to inject it into your $PATH setting, place a text version (not image) of your Oracle directory path for assistance.
skullnobrains

you are missing a quote after the =
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
skullnobrains

the shell chokes on the '(' which is the first character it will not accept in an unquoted string. said chain ends with a quote which makes pretty obvious there should be a starting one as well.

you can also remove the ending quote and escape the parenthesis.

that said, the folder might also be wrong. if the path contains no character special to the shell, you don't need quoting.

... but that has no relation whatsoever with why ubuntu won't start. the wrong quoting is what prevents it from starting.