Link to home
Start Free TrialLog in
Avatar of J.R. Sitman
J.R. SitmanFlag for United States of America

asked on

Remote Desktop security

I just began to test users connecting via Remote Desktop.  

When I log in as a user they can see all the folders, but cannot access the ones they do not have permission to.

In Active Directory they cannot see the folders they do not have access to.

I have ABE set correctly but users can still see the files

User generated image
Avatar of kevinhsieh
kevinhsieh
Flag of United States of America image

ABE only applies to access via SMB shares. It does nothing for local storage.
Avatar of J.R. Sitman

ASKER

Can you elaborate?
You are trying to use ABE to hide folders that users don't have access to. That only works on file servers. You cannot hide local folders via permissions. You can only hide folders by setting the hidden attribute, which will hide from all users.
The folders I'm trying to hide our on a file server.
Is the file server the terminal server?
No. I'm connecting from home to our office

In Active Directory they cannot see the folders they do not have access to.

What do you mean? On the actual DC? Also, ABE is not live, if you go to a share and setup change ABE after viewing the content, you need to logoff and on again

Let's say I log on to the File server and I can see 25 folders.    I then log on as a user and because of the permissions, I have on the folders the user can only see 10 folders.

If I connect to the file server from outside the company and log on as the same user, they can see all 25 folders.    They just cannot access all 25, only the 10 they have permission to.
I still need feedback on my last post
ASKER CERTIFIED SOLUTION
Avatar of kevinhsieh
kevinhsieh
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Re-engaged with the question.
Thanks