We help IT Professionals succeed at work.

internal email relay problem

Eprs_Admin
Eprs_Admin asked
on
Hi Experts,

I have a problem with sending an email from a server to Exch2019.
When I send an email witout attachment, then it works.
When I send an email with attachment (PDF) then it fails.

Please can you help me to troubleshoot ?
Any Ideas ?
Comment
Watch Question

Eprs_AdminSystem Architect

Author

Commented:
I get this error, when I check the receive connector log

Remote(SocketError)
Hello ThereSystem Administrator
CERTIFIED EXPERT
Distinguished Expert 2018

Commented:
It might be a message or an attachment size limit
CERTIFIED EXPERT

Commented:

Or an anti-virus solution which is throwing an error.. Check your logs.

David FavorFractional CTO
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
As Hello There mentions...

If any SMTP MTA between your sender + recipient has a size threshold less than your attachment size, then your message won't be delivered.

As bleeuwen mentions, refer to your sending logs + also your receiver logs (if you're running the receiving MTA) for the exact reason for the failure.

Tip: Regarding logs, better to test, measure + know, than guess. Always refer to your logs for reasons for failures.

Tip: You can also use SWAKS to send your message on the command line, to see every step of your SMTP conversation in realtime, including any errors.
Jeff GloverSr. Systems Administrator
CERTIFIED EXPERT

Commented:
I would look on your Receive connector you are using for Relay and see what the maximum size limit is.
Eprs_AdminSystem Architect

Author

Commented:
Hi All,

thanks for all the help and infos.
I could check it in powershell with send-mailmessage

This email with attachment was received :-)
System Architect
Commented:
I could check it in powershell with send-mailmessage

This email with attachment was received :-)