We help IT Professionals succeed at work.

IP Address Problem

High Priority
68 Views
Last Modified: 2020-02-26
Hello,

My IP address has changed from India to Hong Kong, I guess because of AVG anti-virus. How can I get this back.

-San
Comment
Watch Question

Kesavan JeganarayananIT Consultant
CERTIFIED EXPERT

Commented:

Is your computer connected to network switch?

You can run the command prompt and type 

Ipconfig /flushdns

and try again ipconfig /release 

Ipconfig / renew 


Hello ThereSystem Administrator
CERTIFIED EXPERT
Distinguished Expert 2018

Commented:
My IP address has changed from India to Hong Kong
Can you please clarify this? If you use DHCP and you changed the location/connected to a different network, you get a new IP address.
CERTIFIED EXPERT

Commented:
I guess because of AVG anti-virus.

Your anti-virus wouldn't normally have anything to do with your IP assignment. This would be obtained from your ISP or the network you're connected to

Are you using the AVG "Secure VPN" service??
Sanjay GandhiFounder, Kenhal

Author

Commented:
Yes, I am using AVG Secure VPN service.
CERTIFIED EXPERT
Commented:
I'm sure you're connecting based on your location and VPN availability

Have you tried changing the settings for the VPN server location?

    Double-click the AVG Secure VPN icon on your desktop to open the application.
    Click Change location to select a server location.
Sanjay GandhiFounder, Kenhal

Author

Commented:
Yes, I checked. It shows Hong Kong. That is why it shows Chinese language on browsing. India is not there in the list.

I guess by selecting Australia, or any English country, the language will appear as English.
CERTIFIED EXPERT

Commented:
That is why it shows Chinese language on browsing

I wasn't aware that was part of the problem, that is odd..
The VPN server shouldn't be overriding your language settings. But you could check to make sure

If your desired location isn't available then you would select the nearest server location. But if that's causing a language issue, then you might want to do as you indicated
Sanjay GandhiFounder, Kenhal

Author

Commented:
Thanks Kenfcamp.

It worked. It was AVG Secure VPN setting which had Hong Kong as my location selection. I called them up also. They said that they don't have dedicated Servers in India, so they use Hong Kong server for India. So we had to select Hong Kong as location. Therefore as of now in Feb 2020, the situation is that in India, if we use AVG Secure VPN, then we have to choose Hong Kong as nearest location.

But because my browser changes to Chinese language by choosing Hong Kong, so I have chosen Australia in AVG software as a location. This gives me English language in my browsers. But sure my location will remain Australia in browsers as well. However, if my Sign-in is from my Account which is India locale, it supports English language from Australia and locale from my Sign-in - strange but true.

Thanks again,

San.
CERTIFIED EXPERT

Commented:
My pleasure Sanjay,