We help IT Professionals succeed at work.

SCCM Client Install not working

jskfan
jskfan asked
on
Medium Priority
36 Views
Last Modified: 2020-03-09
SCCM Client Install not working

I have tried to install client on  computers in a collection. However after waiting for hours, I went check back and found that the client is not installed in any of the computers inside that collection I pushed the install to.

After looking around I found that there is something wrong with the Management point... This is a LAB so all of the Roles are on the same server.
a
Comment
Watch Question

Sean BravenerSenior Information Technology Consultant
CERTIFIED EXPERT
Awarded 2019
Distinguished Expert 2019

Commented:
if you go to one of the end points you are trying to install on, do you see a c:\windows\ccmsetup folder?

Author

Commented:
yes I do ..
I went to that folder also opened ccmsetup log file and saw at the bottom of the file this failure:

ccmsetup failed with error code 0x87d00454
Sean BravenerSenior Information Technology Consultant
CERTIFIED EXPERT
Awarded 2019
Distinguished Expert 2019

Commented:
can you please scrub the logs and post the complete or at least 2nd half of the ccmsetup log?  that one line alone is not super helpful

Author

Commented:
probably related to this. it was Https only..I changed it to Https and Http.
I will test it and see.
a

Author

Commented:
After I did that change at the site level, I was able to do it at the Management point level too:
a

Author

Commented:
sure attached here
ccmsetup.log

Author

Commented:
I added the account at the site /Properties:
a

Author

Commented:
also changed from HTTPS to HTTP on the DP properties:
a

Author

Commented:
Sorry , I am just giving you status of what I am seeing in SCCM.
I noticed that I cannot add Boundary to Boundary Group ...
aa

Author

Commented:
Active Directory Forest was not enable. I just enabled now:
a

Author

Commented:
Some links suggested adding this Role :
a
Sean BravenerSenior Information Technology Consultant
CERTIFIED EXPERT
Awarded 2019
Distinguished Expert 2019

Commented:
do a search for the SCCM prereq checker.  run the checker and it will enable all the features you need for each role. I do not recall of the top of my head all the prereqs.  But the checker has never steared me wrong.  

Author

Commented:
Actually the install of SCCM passed all the Prerequisites , otherwise SCCM will not be able to be installed successfully
Sean BravenerSenior Information Technology Consultant
CERTIFIED EXPERT
Awarded 2019
Distinguished Expert 2019

Commented:
there are things that are technically prereqs that do not trigger a fail.  like the iis 6 components you have listed.  also there are things that are role specific that get installed when you install a role like WDS or IIS components.  However sometimes those extra components fail which is where the prereq check is a godsend.  the prereq checker will install those extra compoents before they are technically needed making for a cleaner install.

Author

Commented:
How do I rerun the Prerequisite checker after I have installed SCCM...
Should I do the same just like installing SCCM from scratch ?
Senior Information Technology Consultant
CERTIFIED EXPERT
Awarded 2019
Distinguished Expert 2019
Commented:
this is the tool I am speaking of.
https://gallery.technet.microsoft.com/ConfigMgr-2012-R2-e52919cd

give it a look and see what it can do for you.

Author

Commented:
the Tool completed with this recommendation:
a

Author

Commented:
I went and installed the missing Features following this link: https://docs.microsoft.com/en-us/configmgr/core/plan-design/configs/site-and-site-system-prerequisites#bkmk_2012MPpreq


I re-run the Tool again, and got the same recommendation

Author

Commented:
I found this error in SCCM:
a

Author

Commented:
Uninstalled then re-installed SCCM from Scratch..
It looks better now.. if any issues ..I will open new Question