Link to home
Create AccountLog in
Avatar of C Emmons
C EmmonsFlag for United States of America

asked on

Why does swapping a Static IP not work?

I have a Windowns NLB Cluster with a static IP.  When I shutdown the NLB Cluster and give the IP to a Virtual IP on a Kemp LoadBalancer it doesn't work.  I can use the same configuration for a new IP and everything works perfectly in the Kemp LoadBalancer.  When I run a tracert on old IP, it  goes to Kemp LoadBalancer but takes a long time -- series of Time Outs.  I'm not a networking person -- why would a changed IP not work, when a new IP will? Thanks in advance.
Avatar of noci
noci

Windows Clustering uses  a weird phenomenon.
It NEVER responds to an arp request with a real MAC address. for the virtual IP... this causes the switch to broadcast it to ALL ports in the VLAN.
So if you configure one system with the real IP all traffic will always  goto to THAT port only. ==> no access.

Windows Clustering cannot work without that method. (The cluster members need to coordinate between the nodes which one will answer which requests).
Avatar of C Emmons

ASKER

Thanks for your reply.  Sorry, but I don't understand.  the Windows NLB is off the network, and then steal the IP and add to a Kemp LoadBalancer as the Virtual IP.  It only communicates very slows to the static IP then.  If I disconnect the Nics of the old servers(Vmware) (with Microsoft NLB and static IP) - it wouldn't know it existed? Can you elaborate - thanks again.  Does something/somehow still know about the old cluster?
ASKER CERTIFIED SOLUTION
Avatar of noci
noci

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
I think that is a possibility.  Thanks for thinking of it - maybe special switch setting - I'll check now.
I could hug you -- there were static maps in the router.  I guess networking just wasn't seeing that and they were created 8 years ago.  I found it in my email when we created them, but my memory surely doesn't go back that far.  Thank you so much !!!
no problem.