We help IT Professionals succeed at work.

Cannot map network drive to WEBDAV

BP88
BP88 asked
on
High Priority
54 Views
Last Modified: 2020-03-18
I have setup WEBDAV on a Windiows 2016 server. I can connect fine to it using the URL in a browser, but cannot map a drive to it or even add a network location.

I have tried using several different 3rd party webdav clients and none of them work.

I spent over 2 hours with Microsoft support last night and they could not figure it out either.

I have tried 2 different Windows 10 machines as well with the same results.

attempting to map
Comment
Watch Question

CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
How did you setup webdav, is it a Sharepoint server, or...?
Hello ThereSystem Administrator
CERTIFIED EXPERT
Distinguished Expert 2018

Commented:
A few suggestions:
1. Make sure that WebClient service is running.
2. Have you tried to add the location with CMD?
net use drive_letter: \\sitename@ssl@port/folder/subfolder password /user:userID

Open in new window

3. You can try to modify the registry to accept basic authentication for SSL.
https://support.netdocuments.com/hc/en-us/articles/205212850-WebDAV-as-a-Mapped-Drive
4. Internet options -> Security tab -> Trusted sites -> Sites -> add the site
5. A similar problem was discussed here. It might be worth checking it:
https://answers.microsoft.com/en-us/windows/forum/windows_7-networking/ftp-server-error-the-folder-you-entered-does-not/2d919979-badd-4134-909e-645028fe56b8
BP88President

Author

Commented:
"A few suggestions:
1. Make sure that WebClient service is running.
2. Have you tried to add the location with CMD?
net use drive_letter: \\sitename@ssl@port/folder/subfolder password /user:userID

Select all
 
Open in new window

3. You can try to modify the registry to accept basic authentication for SSL.
https://support.netdocuments.com/hc/en-us/articles/205212850-WebDAV-as-a-Mapped-Drive
4. Internet options -> Security tab -> Trusted sites -> Sites -> add the site
5. A similar problem was discussed here. It might be worth checking it:
https://answers.microsoft.com/en-us/windows/forum/windows_7-networking/ftp-server-error-the-folder-you-entered-does-not/2d919979-badd-4134-909e-645028fe56b8"

1. yes it is running
2. yes, gives error 67
3. I will start here and let you know what happens.

Thanks!
Philip ElderTechnical Architect - HA/Compute/Storage
CERTIFIED EXPERT

Commented:
Step 4.4 is your clue: https://blog.mpecsinc.ca/2019/05/sharepoint-online-setting-up-webdav.html

EDIT: Found another post: https://blog.mpecsinc.ca/2008/06/sbs-20038-sharepoint-mapped-network.html

We've done a lot of SharePoint work and still do. Mapping a drive letter makes things so much easier.
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
We don't even know if you are using SharePoint, @BP88. I am still waiting for your feedback.
BP88President

Author

Commented:
sorry guys, not using sharepoint. just setup webdav in IIS. I have tried all the above suggestions and nothing has worked.
Philip ElderTechnical Architect - HA/Compute/Storage
CERTIFIED EXPERT

Commented:
Paste this into the Address Bar in File Explorer:
\\YourServerNAME\DavWWWRoot\

Open in new window


Depending on how security is set up on the root you should get prompted for a username and password.

Replace YourServerNAME with the IP if that did not work.

Otherwise, there is probably a setting that is not configured correctly.

The above links are for SharePoint, but setting up a WebDAV access in IIS is the same thing.

EDIT: Make sure Web Client in Services.MSC is started and set to Automatic! Otherwise it won't work.
BP88President

Author

Commented:
\\YourServerNAME\DavWWWRoot\ does not work, but if i add @SSL (\\servername@SSL\DAVwwwRoot\) it does ask me for username and password, but again it will not connect
Philip ElderTechnical Architect - HA/Compute/Storage
CERTIFIED EXPERT

Commented:
Okay, then that's the root.

Domain\UserName
UserName@Domain.Com

Make sure the user has FULL on the root folder and subfolders in NTFS and make sure the IIS permissions are set up correctly for folder access.

EDIT: And again, make sure the Web Client service is running on Windows desktop OS.
President
Commented:
So the problem ended up being that webdav was enabled on the virtual directory instead of the Default website.