We help IT Professionals succeed at work.

Windows 10 Black Screen when accessed by remote desktop

High Priority
56 Views
Last Modified: 2020-03-22
Remote Desktop Black Screen issue.  A lot of our computers show a black screen when we try to connect via remote desktop.  They are all windows 10 machines.  Any advice would be appreciated
Comment
Watch Question

Éric MoreauSenior .Net Consultant
CERTIFIED EXPERT
Top Expert 2016

Commented:
this is a setting to reduce the required bandwith and improve performance
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
It would be helpful to know the version (windows 10 built number) of both sides.
For example "10.0.18363.720"
Éric MoreauSenior .Net Consultant
CERTIFIED EXPERT
Top Expert 2016

Commented:
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
It's not about a black background, if I understand correctly, but about a black screen, completely black, right?

Author

Commented:
yes. completely black
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Ok...and what build number is it (both ends, please)?
Can be determined using the command
winver
or simply
ver

Author

Commented:
version 10.0.18363.720
CERTIFIED EXPERT
Distinguished Expert 2019
Commented:

Author

Commented:
thank you. still not working. it is now multiple computers  also when screens timeout only way to view is a reboot
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
The link I gave you tells you to use a certain GPO - did you do that? Afterwards, the client needs to apply that GPO AND reboot. Did you do that reboot and verify if that GPO has applied?

Author

Commented:
i do not see that as an option. the closes is Use the hardware default graphics adapter for all Remote Desktop service sessions
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
I donn't know, but it seems you took a wrong turn when navigating to
Computer configuration -> Policies->Windows Settings->Administrative Templates->Windows Components->Remote Desktop Services->Remote Desktop Session Host->Remote Session Enviroment],

There's the policy "Use WDDM graphics display driver for Remote Desktop Connections" which you need to set to "Disabled" ->restart windows afterwards.

Author

Commented:
so sorry. I still do not see. I am looking in my default domain policy. should I be looking somewhere else
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
If the following is missing for you, that could mean that you don't have the latest administrative templates installed:
Annotation-2020-03-19-212447.png

Author

Commented:
ok. I see it on local computer GP. I will try that tomorrow

Author

Commented:
sorry to say the group policy change did not work. thank you
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Did you restart the machine afterwards or just shut it down and turn it on again?

Author

Commented:
I did a restart
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Ok, that's that.

I'd do tests with cleanly installed machines with no additional software and see if you can connect to those from the same machines you are connecting from.

Also the other way round; connect from those clean machines to the machines you are having problems with.

Author

Commented:
didn’t work on all machines but did work on a few. thank you very helpful

Author

Commented:
thanks again