We help IT Professionals succeed at work.

Mapped drives and GPO

TPBPIT
TPBPIT asked
on
I have a GPO dedicated to mapping drives for my entire company on there desktop/laptop; however, I need to add a special mapped drive for when the log into our Citrix infrastructure.  I have created new GPO and in the User section added my Mapped Drive and set it to map to %userprofile% and set the drive letter.  I set that GPO to be applied to certain users when they log into Citrix, but it doesn't map the drive.  I have tried setting the Loopback on that policy to merge, but still not luck.  I've even tried to change the variable to c:\Users\%username%, but still no luck.  And I tried a batch file that works if you run it while logged in, but won't run from the Logon Script portion of the GPO.  I really want to do this with the Mapped Drives function of the GPO, but I'm at a lose.  Any thoughts would be greatly appreciated.
Comment
Watch Question

Carl WebsterCitrix Technology Professional - Fellow
CERTIFIED EXPERT
Most Valuable Expert 2019
Top Expert 2010

Commented:
Can you show us what you have?
Have you tried a separate GPO linked to your Citrix related OU?
CERTIFIED EXPERT

Commented:
hi,
where do you place this special drive-mapping policy (should be placed within the TS-OU)
where do you configure the loopback policy? (shoud be configured within the TS-OU too)

Author

Commented:
The mapped drive GPO is separate from my all encompassing GPO for Citrix users.  The policy for the special drive mapping is linked to the OU that my Citrix XenApp Servers live in.  The merge is set in the same GPO that has the special mapped drive. The GPO is enabled.
CERTIFIED EXPERT
Top Expert 2015

Commented:
This can get a little complex because we don't know if you have conflicting GPO for example so I will try to help in high level.

Do you have any other GPO for the Citrix user group?  Test to see if the GPO is getting applied.  If you can confirm this then try to see if you can just map one folder instead of using symbols, for example try to share "C:\tempshare".  If it works then the GPO didn't like "c:\Users\%username%" for example.

Also, in the new drive property try using Update or Replace action instead of Create.  See attached.

Let us know.
download.png
CERTIFIED EXPERT

Commented:
you may use   gpresult -h filename.html    to check if GPO is executed/used and if there are other GPO's negating these settings.

Author

Commented:
Thanks to all that tried to help me.  I fought this for a while last night and eventually abandoned the mapped drive concept and found a workaround to the solution I was trying to create.  Once all the madness is over I'll go back and try to figure out why this didn't work.

On a personal note, I'm sure you guys have your own challenges with work right now.  Thank you for taking time to help me.

Damian
Commented:
Workaround was implemented that didn't use a mapped drive.