We help IT Professionals succeed at work.

Error installing Net Framework Feature on server 2016

ajwellman
ajwellman asked
on
Medium Priority
34 Views
Last Modified: 2020-03-26
I am getting an error when trying to install Net Framework 3.5 feature on a virtual server 2016.  
I get the error "The request to add or remove features on the specified server failed.
Installation of one or more roles, role services, or features failed.
The referenced assembly could not be found.  Error 0x80073701"
I have tried to mount the server 2016 iso and selected the "specify an alternate path" and pointed to the mounted ISO sources\sxs folder and still get the same error.  I have also tried to point the alternate path to an extracted copy of the the ISO and still get the error.
Any suggestions at what else I might try would be appreciated.
art w
Comment
Watch Question

Hello ThereSystem Administrator
CERTIFIED EXPERT
Distinguished Expert 2018

Commented:
Is there a WSUS server? Use it for installing .Net Framework 3.5.

Another way to install .Net 3.5.
Dism /online /enable-feature /featurename:Netfx3 /source:D:\Sources\sxs

Open in new window


Or you can download it:
https://www.microsoft.com/en-us/download/confirmation.aspx?id=25150

Author

Commented:
Thanks for the quick response.

I tried to install via DISM as you suggested but it failed with
"Error: 50
The operations is complete but NetFx3 feature was not enabled."

I have attached the dism log.
dism.log
Hello ThereSystem Administrator
CERTIFIED EXPERT
Distinguished Expert 2018

Commented:
Can you provide this log? %WINDIR%\logs\CBS\cbs.log

I made a little modification...
DISM /Online /Enable-Feature /FeatureName:NetFx3 /All 

Open in new window


I suggested more options... WSUS and downloading the package from Microsoft. Is it possible to try them?

Author

Commented:
Thanks again for the help.
I tried:
dism /online /enable-feature /featurename:Neff3 /all /Source:c:\ws2016-dist\sources\sxs\

but got this error
Error:  14081
The referenced assembly could not be found.

Not sure why it wouldn't find the source. as the C:\WS2016-DIST\Sources\sxs folder contains the cabinet file:
microsoft-windows-netfx3-ondemand-package.cab


I had prviously tried to download the net framework 3.5 download from MS but it wouldn't install.  Just said I had to use the load feature to install.

Thanks
Hello ThereSystem Administrator
CERTIFIED EXPERT
Distinguished Expert 2018

Commented:
Make sure there are no pending updates and reboot the server if posible. If you use the command I provided without the /source part, it will use Windows Update to download the file.
DISM /Online /Enable-Feature /FeatureName:NetFx3 /All 

Open in new window

Btw. Is there a server WSUS involved?
I could not get the Net Framework 3.5 installed so ended up removing and rebuilding the Virtual server and then was able to install net framework.
Thanks for all the help and suggestions.