Avatar of CharlieF2
CharlieF2
Flag for United States of America asked on

Need help connecting RDP over VPN

I have a customer who has a TP-Link Archer C1200 router - which does not appear to support Port Forwarding.  I'm trying to set up Remote Desktop so that they can work from home.  The C1200 router does support OpenVPN.  I set up and was successfully able to connect from my office in IL to their office in MI via the OpenVPN client using the Certificate that their router software created.  Now that I am "connected" I have tried to connect directly to the server - which has an internal IP address inside their LAN of 192.168.1.145.  The VPN connection has assigned my computer inside my office as 10.8.0.6.  When I use the Windows 10 Remote Desktop Connection software with the 192.168.1.145 address - I'm getting the standard "Remote Desktop Cannot Connect" for one of the following three reasons message.  I am sure that I'm missing a couple of steps.  Please offer any and all suggestions!  Thank you in advance for your time!
* RDPVPN

Avatar of undefined
Last Comment
CharlieF2

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
David Johnson, CD

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
CharlieF2

ASKER
Hello David,
Thank you for your response.  I read and ran extensive tests using the information contained in Chapter 11 of the user manual.  Their use of the term "port forwarding" is not consistent with other router's capabilities for true port forwarding.  Their "virtual servers" feature is an interesting feature but it is not suited for RDP port forwarding and when I've attempted to use this feature for RDP - it simply won't work.  

I'm not able to change my customer's LAN range.  The customer's LAN is a 192.168.1.x range.  My home LAN is a 10.0.0.x range.  The VPN is currently giving my computer a 10.8.0.6 IP address.  There doesn't appear to be any conflict here of any kind.  I'm still not able to figure out why once the VPN is connected, I cannot ping or connect via RDP the computer in my customer's offices.  

Any ideas - anyone?  

Thank you again for taking a moment to ponder this issue.  
David Johnson, CD

then the customer should configure routing and remote access and route from the vpn network to the internal network.
strivoli

What results do you get when you tracert destination IP?
Can you disable SERVER's Firewall just for a while and try?
Your help has saved me hundreds of hours of internet surfing.
fblack61
CharlieF2

ASKER
Hello Strivoli,

Thank you for your comments and suggestions.  I tried a TraceRt - The request simply times out with each attempt.

Are you referring to the Windows Firewall or a Router Firewall?  Please let me know.  Thank you!
strivoli

Tracert times out? This isn't good. "Route Print" doesn't give you any usefull info?
I'm referring to the Windows Firewall.
CharlieF2

ASKER
David,
It turns out that the Windows Firewall settings that I had enabled for allowing / enabling RDP were not working until I rebooted the computer for some reason.  I rebooted the customer's computer and re-tried the Port Forwarding / Virtual Server option with the Archer C1200 Router - following the instructions in Chapter 11 and the Remote Desktop worked - using plain old direct RDP.  I uninstalled the VPN software and have turned off the VPN option on the customer's router.  Technically, my question was not answered but more importantly, my need was met - which is how to get RDP working with this particular router.  So thank you for taking time to help me with my problem.  

Thanks also to strivoli as well.  

Take good care and stay healthy!

⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.