Link to home
Start Free TrialLog in
Avatar of ddantes
ddantesFlag for United States of America

asked on

Logical drive becomes unavailable

Running Windows 7 Professional 64-bit.  A logical partition was created on my notebook's hard disc, and given a drive letter (I:).  For a while, the disc worked as expected, and then I was unable to open it.  There was an error that the drive letter refers to a destination which is unavailable.  If I use DiskPart, and assign drive letter I: to that volume, everything works again.  But only for a while.  I've never encountered this before, and would appreciate any guidance about how to prevent it.  The other volumes don't have this issue.
Avatar of Hello There
Hello There

Can you share the error you got?

Are there any data on the drive? Can you format it and assign the letter again?
Look in the system's event logs and see if there is anything that might indicate what occurred.  In particular look for disk-related things such as bad blocks.

Is this volume a primary partition or an extended partition?

Is the drive itself showing any SMART errors?

Can you show us a screenshot of Disk Management showing the drive in its expected and current states?
Avatar of ddantes

ASKER

Thank you both for comments.  Right now, the issue is not present.  After posting this question, I realized that drive letter I:  had caused a problem recently.  I moved programs and data to a new notebook, using an application called ZInstall.  The process left a phantom drive I:  which was removed with the subst command.  Perhaps that history is contributing to the issue.  I've changed the drive letter of the logical partition, and I'd like to wait and see if the issue occurs again.  I'll post after a couple of days.
try giving it a fixed drive letter : http://www.uwe-sieber.de/usbdlm_e.html
Avatar of ddantes

ASKER

I reassigned a different drive letter, and everything was OK for a couple of days.  Then, the drive letter of that volume reverted to I:, and it became inaccessible.  That happened without my intervention.  Using DiskPart subst I: /d  removed that letter, and the Assign command assigned a new drive letter, which is now accessible.  I'd like to avoid having this happen, if there is a way to prevent its reoccurrence.
did you try uwe sieber's way?
Avatar of ddantes

ASKER

Nobus, that link describes a tool which is applicable to USB drives.  The volume in question is a partition on the system hard drive in my notebook, so I did not try that solution.
are there any gpo rules active?
is it your personal laptop, or one that came from a company ?
Run with elevated permissions: mountvol /r
= Removes volume mount point directories and registry settings for volumes that are no longer in the system, preventing them from being automatically mounted and given their former volume mount point(s) when added back to the system.

Then: HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices -> Anything related to the I:? If yes, delete it.
Avatar of ddantes

ASKER

Thank you. I don't know what GPO rules are, and I haven't configured any such rules.

This is a pre-owned machine.  I migrated programs and settings to it with an application called ZInstall.  The source notebook uses I: on a logical partition, and there never is an issue with it.  I ran the mountvol command, and found no reference to I: in Mounted Devices afterwards.  However, after a reboot, a phantom drive I: appeared in Windows Explorer (screen shot attached).  User generated image
Although I would prefer to avoid this, as long as the real volume remains accessible, and its drive letter is not reassigned to I:, it's not a critical issue.
here's how to look up your group Policy rules :  https://www.howtogeek.com/116184/how-to-see-which-group-policies-are-applied-to-your-pc-and-user-account/
since it was owned before - you may have inherited  some
ASKER CERTIFIED SOLUTION
Avatar of ddantes
ddantes
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of ddantes

ASKER

Thanks to the Experts who participated!