Avatar of David Barman
David BarmanFlag for United States of America asked on

Remote Desktop 2012 - Outlook 2016 won't search the task items

I have a strange issue.  On a Remote Desktop Server (2012). In Outlook 2016, the user can search mail items but when tasks are searched no results are ever found.  I have tried re-creating the user profile.  We are in an on-premise Exchange 2016 environment.  I also re-built the search on the Exchange server.  However, the results are the same.

Any ideas?
Remote AccessExchangeOutlookWindows Server 2012Desktops

Avatar of undefined
Last Comment
M A

8/22/2022 - Mon
Amit

What is the result using OWA? Also set outlook in online mode and test again.
ASKER
David Barman

I have looked in OWA.  I can't seem to find an option for search.  The RDS user is already setup in online mode.
Cláudio Rodrigues

Is the search service running on the RDS box?

CR
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
ASKER
David Barman

Yes. The search service is running
Cláudio Rodrigues

Is Outlook 2016 fully patched to the latest version? This was an issue with certain builds in the past where a particular build would break tasks search as an example.

CR
ASKER
David Barman

It is version 16.0.4266.1001
I don't see a check for updates option.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Cláudio Rodrigues

I would go here and try to update all the Office components you are using (try a test or separate server):
https://support.microsoft.com/en-us/help/4538705/march-2020-updates-for-microsoft-office

CR
ASKER
David Barman

I have installed updates. In addition, I noticed today while working on one of the Windows 10 computers on the network (for the same user) that the same search issue exists.
Could this be an exchange server issue?
Cláudio Rodrigues

If the same user on another system has the issue, do you have roaming profiles in place? Also on that same Windows 10 computer, if you logon as another user, is the issue there? If it is, it is almost certainly something wrong on the backend (Exchange).

CR
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
ASKER
David Barman

No. The user doesn't use roaming profiles. At this point I don't know if other users have issues
ASKER
David Barman

Another update.  I logged into the remote desktop server as two other users.  The first user had the same search issue in the Outlook tasks.  However, the next user I tried, I was able to search the tasks.

Any ideas?
ASKER
David Barman

Upon closer inspection.  It appears that the search issue is in the  "To-Do List".  If I select the user's task folder, it will search.Is there a known bug about the To-Do List?

Any ideas what would cause this?
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
M A

What happens if you try with a different user?
ASKER
David Barman

I have tried it with multiple users and the same symptom exists.  
ASKER CERTIFIED SOLUTION
M A

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question