Avatar of TK
TK
 asked on

Exchange 2010 Receive Connector

I have an external service that will be relaying through our Exchange environment. IT will be sending to both internal and external recipients.  The service is configured for SMTP authentication over port 587.

My settings on the connector are TLS and Externally secure for authentication tab and Exchnage Servers for Permission tab.

However it fails when testing on the external service end and when i check the SMTP Receive logs in only see the below.

SMTPSubmit SMTPAcceptAnyRecipient SMTPAcceptAuthenticationFlag SMTPAcceptAnySender SMTPAcceptAuthoritativeDomainSender BypassAntiSpam BypassMessageSizeLimit SMTPAcceptEXCH50 AcceptRoutingHeaders
220 Servername Microsoft ESMTP MAIL Service ready at Fri, 10 Apr 2020 11:11:09 -0400
EHLO f23afa3dd522
250-servername Hello [x,x,x,x]
250-SIZE 27262976
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-AUTH
250-8BITMIME
250-BINARYMIME
250-CHUNKING
250-XEXCH50
250 XSHADOW

The session disconnects after that.

It's been a while when i've had to setup something similar to this, so i want to make sure my configuration is correct.

Thanks in advance.
Exchange* SMTP

Avatar of undefined
Last Comment
M A

8/22/2022 - Mon
M A

Hi TK,
Please ensure authentication is configured in the remote server which is trying to send email through this server.

If that doesnt work I suggest you to create a dedicated receive connector and allow only that IP to send email.
TK

ASKER
Hi MAS,

Thanks for the quick reply. The service does allow for auth. Take a look at the screenshot. Right now i have a dedicated RC for this server which allows 2 Remote IPs. I can see those connections in the smtp protocol logs as i suggested above. I've attached the screenshot of the srvice and my recieve connector settings.
SMTPsettings.PNG
permissiontab.PNG
authtab.PNG
M A

-->SMTPsettings.PNG
Is this saved successfully. Is there a way to test from your cloud app?
If possible test it and post the screenshot.

--> permissiontab.PNG
Please tick Exchange Users only. Restart Exchange Transport service
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
TK

ASKER
Yes it is saved successfully. However i can't uncheck Exchange Servers and leave Externally secured checked. For me to use Externally secured i need to also have Exchange Servers checked.

I can test from the external site but it fails with the attached error.
error.PNG
TK

ASKER
so i was able to get this  to working using the default "Client Servername" connector that listens on 587. By disabling the custom 587 connector i created, it forced the service connection through the client servenrname connector and it worked.

However if i set the custom connector identical to the client servername connector, it still won't working using the custom.

Is this result intended?
ASKER CERTIFIED SOLUTION
M A

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.