Link to home
Start Free TrialLog in
Avatar of Jim Klocksin
Jim KlocksinFlag for United States of America

asked on

Windows 2016 Server RDP Printing not working

I've recently deployed my software applications, that run as RemoteApps, from my network which was running a Windows 2008 R2 Server over to my client's network running a Windows 2016 Server.  The printing via "redirected" printers is not working on the new W2016 Server.  When users attempt to print a report, the Print Dialog box shows ALL of their local printers (as redirected), but when they actually attempt to print to any of the redirected printers nothing prints.  As a work-around solution they are able to print to PDF files, stored on a shared network drive, then they are able to print the PDF files, like any other "printable" file, from their local desktops.  For a limited time they've allowed me to have control over Group Policy on the server, so I'm able to change GPO settings.  I've set all the GPO settings related to printer redirection thru RDS that I'm aware of and still nothing will print.  Has anyone had any similar experiences running RemoteApps under Windows 2016?  Any tips would really be appreciated.
Avatar of Irwin W.
Irwin W.
Flag of Canada image

  • Can you confirm what models of printers your staff are using?
  • Do you have Windows Easy Print driver enabled for use?
Avatar of Jim Klocksin

ASKER

First of all, my client is a huge, global corporation (one of the companies on the DOW), so no, I have no idea what kind(s) of printers they have or might have in the future and, frankly, who cares?  Windows should be able to print to any printer (remember, the old catch-phrase "device independence").  They also have some type of system print they call a "badge" printer, that every employee can use, send their print jobs to this badge printer, then go to the physical location where the badge printer is located, swipe their badge, and the printer will print any report(s) that the "badge identified" person has sent to that printer.

I'm not sure what you're referring to when you say "Windows Easy Print", but if you're referring to the "Use Remote Desktop Easy Print printer driver first" GPO option, I have that one disabled!
  • You need to have Windows Easy Print driver.
  • Take a look at your Windows even logs, can you provide some errors related to printing?
  • Not all printers are supported and it could also be that the version of their printers are no longer supported by Windows 2016 due to their age, when you consider that you previously had a Windows 2008 server
I've looked at the event logs and there are no errors being generated.  I still don't know EXACTLY what you are referring to when you talk about the "Windows Easy Print" driver.  And, finally, even if I believed that newer Windows versions were dropping support for older devices, that doesn't explain why not a single printer (on their entire network) is working.....Windows 2016 didn't drop support for ALL of their printers!
I am trying to provide you with possibilities based on my experience with numerous RDS implementations I have completed over the last 5-10 years:
  1. Can you please provide a sample set of remote systems and the model of printers attached to their remote computers
  2. Can you please provide the error and screenshot of the error clients are receiving
  3. Have you tried to print and what error are you receiving(screenshot also please)
  4. Here is some more information on Windows Easy Print driver.  The article is a bit dated however the GPO requires a minimum of Windows 7Server 2008 for compatibility http://techgenix.com/how-configure-microsoft-rds-universal-printing/
  5. Sometimes you may have to install the Windows driver on the Windows RDWeb server in order for the printer to be recognized.  Windows potentially may not have the necessary and compatible drivers in its driver cache for use. See my other recent post on this with another EE member.  CLICK HERE

Don't misunderstand me, I do appreciate that you are taking your valuable time to respond to my question (and I might add that no one else is, to this point).  Problem is that the corporate site that's using my application is located in SE Pennsylvania and I'm in Florida.  I, frankly, have no idea what printers are used by the users of my application (and, further, the users of my application today, for the most part, are not the same users that used by application 5 years, 10 years, 15 years, or 20 years ago!).  Please understand this point as well, I have over 500 active users who are normally located throughout this huge work site (most are currently working from home), so to get any information regarding the types of printers they are using is next to, if not totally, impossible.

Next, to reiterate, there are NO error messages being generated for either my users or myself.  The print job appears to complete successfully, but when the users look in the print queue for whatever printer they sent the job to, there is nothing there!  Hence, NO ScreenShots!

I will look at the links you provided for the Windows Easy Printer, but, again, I'm dubious about this being the solution, simply because everything was working fine when the RemoteApps were running off my network (i.e. no printer issues) albeit that was a Windows 2008 R2 Server running RDS.
Going back to your original issue:
 I've recently deployed my software applications, that run as RemoteApps

Are other applications in your client's environment printing properly from RDS?
I know this sounds like a strange situation and, frankly, it is.  The reality is that the server my RemoteApps are deployed on was provisioned (along with a TEST server, which is working the exact same way) for my RemoteApps only.  There is nothing else running on this server and there never will be.  So if there are any other applications running on my client's network as RemoteApps, they're running on other servers (which may or may not be running Windows 2016) and it's not really an "apples to apples" comparison.  There's something unique about the setup of these servers that is not allowing for printing to actual printers.  Like I said at the outset, the reports can be "printed" to PDF files and that works fine.  They have some of their own people looking into this problem, and they realize that it's their problem and not mine.  But, that said, I have no idea how soon their "outsourced" IT "specialists" will actually even start working on this, much less when they'll ever resolve it.  I just wanted to see if their was something different about Windows 2016 and Group Policy under W2016 that anyone knew about that could resolve the issue.
Have you tried setting up a 2016 RDS environment and testing your application?

I mean sure, it works on 2008 but that's not the environment it is run on. 
I get what you're saying but
1) The RemoteApps are up and running on my client's network, all program logic is working normally, the application sends out both emails and text messages (to the tune of 100 to 300 texts per day), and prints to PDF with no problem.  So the application is working in a Windows 2016 environment.
2)  I'm currently in Florida, but will be leaving for New Jersey in a week.  Once I get to New Jersey I have 2 weeks to pack up all my belongings in a house that we've lived in for over 18 years, close on that house, close on the townhouse we're moving to, then unpack.

My point is that I don't have the time to do what you're suggesting.  The point of my question on here was to find out if anyone had a "straightforward" solution (preferably using Group Policy) to quickly resolve the problem my client is encountering with printing.  I've already spent a lot of time learning as much about Windows 2016 as I really care to know and have been able to get my client base to a point where they are functioning.  Up until 2 weeks ago, they were running my application on my network located in the house that I'm selling.  Since transferring the application to my Florida location was not an option from my client's point of view, I had no choice other than to move it to their network and to a Windows 2016 server.  Bottom line, I just don't have the time (or inclination, frankly) to set up a 2016 environment on one of my servers, just to see if the printing works or not.  I suspect that it would work on my system and that there's some security setting or software that's blocking it from printing on their network, since I haven't been able to find anything on the Internet that points me to any GPO or even a Registry setting that would resolve this issue.

Thanks for your time, but unless you (or someone else) can point me to a simpler, and much less time consuming solution (given my current situation), I'll just let my client's IT staff deal with this!
ASKER CERTIFIED SOLUTION
Avatar of Jim Klocksin
Jim Klocksin
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial