Avatar of steveurich
steveurichFlag for United States of America

asked on 

File copies from QNAP Raid to attached external USB 3 drive is beyond slow.

I have a QNAP TS-453Pro NAS server. It has 4 USB ports on the back, 2 USB2, 2 USB3.

Before I start messing with me 650GB of photos I wanted to back them up to an external drive connected to the USB 3 port. The file copy performance was terrible, in the KB range often. The copy was estimated to complete sometime in Jul.

I tried moving them to the USB 2 ports and the performance was somewhat better but not what I would have expected.

QNAP support is terrible.

I am running the most current version the Firmware.

I am not sure how the USB ports are connected in the system. If it could be a module that I could replace.

While I have invested a lot of time learning the QNAP I am not sure I would get another but I was thinking of maybe upgrading and just getting new hardware to fix the problem.

Any suggestions on how to troubleshoot the USB ports on the QNAP.

I saw some posts on their forums that mention this problem but do not mention the solution.
NASHardware* Qnap

Avatar of undefined
Last Comment
Avatar of E C
Flag of United States of America image

Yes, QNAP support IS terrible. This is the number one reason I switched to Synology. That being said QNAP makes good stuff. The external drive you are plugging into the NAS device, is it a USB 3 device?  (Remember, USB3 is backwards compatible. You can plug USB2 devices into a USB3 port all day long but you're not going to get speeds faster than your slowest link).

Have you tried this?...
Plug the USB external drive in your computer instead of directly into the NAS. Then from your computer, copy the same files from the NAS to the external USB device. I am not telling you this is the solution. It's only a way to confirm if your external device is slow vs there's something wrong with how the QNAP copies to direct-attached USB devices.

I suspect it's your external USB device. How old is the external USB device? You may want to run diskcheck on it to make sure it does not have bad blocks. Or even better if available, try a different external USB drive.

Also how is the external drive formatted? Fat32? NTFS?
Avatar of steveurich
Flag of United States of America image


I just bought it. it is definitely USB 3. I have 2 disks and they both have the same speeds.
Avatar of steveurich
Flag of United States of America image

Blurred text
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial

Hardware includes cell phones and other digital living devices, tablets, computers, servers, peripherals and components, printers and scanners, gaming consoles, networking hardware such as routers, hubs, switches and modems, storage devices and security equipment such as firewalls and other appliances.

Top Experts
Get a personalized solution from industry experts
Ask the experts
Read over 600 more reviews


IBM logoIntel logoMicrosoft logoUbisoft logoSAP logo
Qualcomm logoCitrix Systems logoWorkday logoErnst & Young logo
High performer badgeUsers love us badge
LinkedIn logoFacebook logoX logoInstagram logoTikTok logoYouTube logo