troubleshooting Question

IIS - Request filtering is configured on the Web server to deny the request because the content length exceeds the configured value.

Avatar of Wayne Barron
Wayne BarronFlag for United States of America asked on
Visual Basic.NETMicrosoft IIS Web ServerWeb Servers
1 Comment1 Solution97 ViewsLast Modified:
I am getting the following error when I upload multiple files to the server.
I am uploading MP3 files.
If I do 1 to 4, it is fine.
But anything from 5 and up, it gives the error.
The files are less than 5mb in size each.


HTTP Error 404.13 - Not Found The request filtering module is configured to deny a request that exceeds the request content length.

Most likely causes: Request filtering is configured on the Web server to deny the request because the content length exceeds the configured value.

Things you can try: Verify the configuration/system.webServer/security/requestFiltering/requestLimits@maxAllowedContentLength setting in the applicationhost.config or web.config file.

web.config (In all WebCore servers)

<httpRuntime executionTimeout="180" maxRequestLength="1048576" shutdownTimeout="90" />
 <security>
   <requestFiltering>
     <requestLimits maxAllowedContentLength="1073741824" />
   </requestFiltering>
 </security>

Open in new window

In the ARR and Web Servers ApplicationHost.config

<security>
   <requestFiltering>
     <requestLimits maxAllowedContentLength ="1073741824" />
   </requestFiltering>
</security>

Open in new window

I found an article on this issue, and I tried what was mentioned which is this.

appcmd.exe unlock config -section:system.webServer/security/requestFiltering

Open in new window

I then found this and applied it to all the servers as well.

appcmd set config -section:requestFiltering -requestLimits.maxAllowedContentLength:1000000

Open in new window

Restarted IIS

net stop wmsvc  
net start wmsvc  

Open in new window


But still, the same error.

Does anyone have any advice they can share with me on this issue?
I have done and tried everything I could find online and nothing works.
I've had this running flawlessly before, I'm talking a few months ago before we lost everything and had to rebuild the Server Farm from scratch again.
And since then, different things have stopped working that used to work.
Components that use to work on the old 2016 DC (The DC was about 3 yrs old)
With the new 2016 DC, stuff has just not been working properly.
I don't THINK the DC would have anything to do with this issue here, at least, I don't think it would.
ASKER CERTIFIED SOLUTION
Wayne Barron
Author, Web Developer

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Top Expert 2009

The Distinguished Expert awards are presented to the top veteran and rookie experts to earn the most points in the top 50 topics.

Join our community to see this answer!
Unlock 1 Answer and 1 Comment.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 1 Comment.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros