We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Issues creating a shared calendar in O365

Medium Priority
26 Views
Last Modified: 2020-06-09
I need to create a shared calendar for our organization in O365 but I am having some trouble.  I thought I set everything up correctly but when I try to view the calendar in Outlook, it is not showing as a calendar but it looks like a mailbox.

I went into O365 admin, Exchange admin center, public folders and created the public folder called "Office Schedule".  Then under "Office Schedule" and set permissions for myself and one other user.  Under that I created a subfolder called "Calendar" as the other shared calendars in my office (previously created by someone else) were set up.

Then I went into public folder mailboxes and added "Office Schedule PFMailbox" as the other previously created shared calendars appeared to be set up, they all say "Secondary Hierarchy".

When I went into my Outlook and went to "Public Folders" the new "Office Schedule" was there along with the rest of the shared calendars under All Public Folders, however, when I expand the Office Schedule folder to reveal the Calendar, the Calendar shows a small blue + sign like the parent folder has, while all the other shared calendars I have show an actual calendar icon with a 2 way blue arrow.

Can someone help me figure out what I am doing wrong?
Comment
Watch Question

CERTIFIED EXPERT
Most Valuable Expert 2015
Distinguished Expert 2019
Commented:
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview
FOXActive Directory/Exchange Engineer
CERTIFIED EXPERT
Top Expert 2015

Commented:
You could have created a shared mailbox and named it Office Schedule - Calendar
YOu could have then set the permissions needed on the calendar of that shared mailbox
Your necessary users could have then added that shared calendar to their outlook

Author

Commented:
I can't right click on Office Schedule when I'm in public folders.  The only way to create the subfolder called "calendar" is to click on Office Schedule and then click the + sign to add a new public folder that I named Calendar.  I just did this to copy what I saw under the other shared calendars we had.  

Same thing with the pubic folder mailboxes, I was just copying what I saw on the other shared calendars, I wasn't sure why I'd need to create the public folder mailbox but I was trying to copy what was there on other calendars.

I don't see any options to select "Calendar items" or an area for "Folder contains".  The only option I have is to go into the Office Schedule public folder and click + which only lets me create the subfolder with Name and Path.  This is all in the Exchange Admin Center under public folders, I wasn't sure if there was another area I needed to be in to accomplish this.
FOXActive Directory/Exchange Engineer
CERTIFIED EXPERT
Top Expert 2015

Commented:
g8 create a shared mailbox as I stated earlier

You could have created a shared mailbox and named it Office Schedule - Calendar
YOu could have then set the permissions needed on the calendar of that shared mailbox
Your necessary users could have then added that shared calendar to their outlook

Author

Commented:
FOX, I will try that tomorrow.  That certainly sounds easier but I was hoping to figure out how to set it up the way all our other shared calendars and contacts are setup.  Not sure why I can't get it to work, I feel like it was close, just have to figure out how to make it a calendar instead of a malbox.
CERTIFIED EXPERT
Most Valuable Expert 2015
Distinguished Expert 2019

Commented:
g8rcub, I'm talking about using the Outlook client, not the EAC. PFs in general are managed via the client.

Author

Commented:
Vasil, thank you, that worked.  I didn't realize public folders were managed at the client.  Also, when I had gone in and right clicked that folder in Outlook yesterday, the option for Calendar items was actually hidden, I had to scroll up and found it.  Now when I go back into EAC, public folders, Office Schedule, the calendar I created in Outlook is showing as the subfolder.  I will remember this for next time.  Now I will add permissions and get everyone set up.  Thanks!

Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.