We help IT Professionals succeed at work.

Can't create VLAN 4094 on my cisco switch

chiprule
chiprule asked
on
62 Views
Last Modified: 2020-07-06
Hi Guy,
when I can't create vlan 4094 on my cisco sg300 switch.
4094.PNGshow-vlan.PNG
Thanks
Comment
Watch Question

bbaoIT Consultant
CERTIFIED EXPERT

Commented:
can i first know if you have reset the router before troubleshooting further?

Author

Commented:
Hi bbao,
do you mean reboot?
Thanks
bbaoIT Consultant
CERTIFIED EXPERT

Commented:
i mean all settings to the factory defaults. see below the details.

http://www.thetechfactors.com/reset-cisco-sg300-switch-factory-default/

Author

Commented:
I made lot of configuration....there aren't any troubleshooting befor factory reset?
Hello ThereSystem Administrator
CERTIFIED EXPERT
Distinguished Expert 2018

Commented:
VLANs 3968 to 4047 and 4094 are reserved for internal use; these VLANs cannot be changed or used.
some oneNetwork Architect
CERTIFIED EXPERT
Top Expert 2014

Commented:
This isn't a Nexus. However, the VLAN is being used already for an internal process on the switch.

Can you show the running config for the switch (omit any sensitive data).
Hello ThereSystem Administrator
CERTIFIED EXPERT
Distinguished Expert 2018

Commented:
I believe this applies to all/most Cisco switches including SG300. The point is that you simply cannot use VLAN ID 4094 because it's reserved for internal use.

Author

Commented:
Ok, the problem is this.
https://blog.scottlowe.org/2006/12/04/esx-server-nic-teaming-and-vlan-trunking/ 
For testing this procedure i must put native vlan 4094
It's a loophole :(



#show running-config
config-file-header

v1.4.11.2 / R800_NIK_1_4_216_022
CLI v1.0
set system mode router

!
vlan database
default-vlan vlan 10
exit
vlan database
vlan 1,50,60,70,80,90,95,200
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
port-channel load-balance src-dst-mac-ip
ip dhcp server
ip dhcp pool network "DHCP VLAN 10"
address low 172.16.10.100 high 172.16.10.200 255.255.255.0
dns-server 172.16.1.1
exit
ip dhcp pool network "DHCP VLAN 60"
address low 10.0.60.100 high 10.0.60.200 255.255.255.0
dns-server 172.16.1.1
exit
ip dhcp pool network "DHCP VLAN 200"
address low 192.168.100.100 high 192.168.100.200 255.255.255.0
dns-server 172.16.1.1
exit
bonjour interface range vlan 1
ip access-list extended RFC1918
permit ip 192.168.100.0 0.0.0.255 172.16.1.0 0.0.0.3 ace-priority 5
permit ip 172.16.1.0 0.0.0.3 192.168.100.0 0.0.0.255 ace-priority 6
permit ip 192.168.100.0 0.0.0.255 192.168.100.254 0.0.0.255 ace-priority 7
permit ip 192.168.100.254 0.0.0.255 192.168.100.0 0.0.0.255 ace-priority 8
deny ip 192.168.100.0 0.0.0.255 10.0.0.0 0.255.255.255 ace-priority 10
deny ip 10.0.0.8 0.255.255.255 192.168.100.0 0.0.0.255 ace-priority 11
deny ip 192.168.100.0 0.0.0.255 172.16.0.0 0.15.255.255 ace-priority 12
deny ip 172.16.0.0 0.15.255.255 192.168.100.0 0.0.0.255 ace-priority 13
deny ip 192.168.100.0 0.0.0.255 192.168.0.0 0.0.255.255 ace-priority 14
deny ip 192.168.0.0 0.0.255.255 192.168.100.0 0.0.0.255 ace-priority 15
exit
hostname
clock timezone " " 0 minutes 0
clock source sntp
sntp unicast client enable
sntp unicast client poll
sntp server pool.ntp.org
ip domain polling-interval 8
ip telnet server
!
interface vlan 1
 name Transit
 ip address 172.16.1.2 255.255.255.252
 no ip address dhcp
!
interface vlan 10
 name Management
 ip address 172.16.10.254 255.255.255.0
!
interface vlan 50
 name "Server Storage"
 ip address 10.0.50.254 255.255.255.0
!
interface vlan 60
 name "Server Group A"
 ip address 10.0.60.254 255.255.255.0
!
interface vlan 70
 name "Server Group B"
 ip address 10.0.70.254 255.255.255.0
!
interface vlan 80
 name "Clients Lab"
 ip address 10.0.80.254 255.255.255.0
!
interface vlan 90
 name "WIFI Group A"
 ip address 10.0.90.254 255.255.255.0
!
interface vlan 95
 name "WIFI Group B"
 ip address 10.0.95.254 255.255.255.0
!
interface vlan 200
 name Home
 ip address 192.168.100.254 255.255.255.0
 service-acl input RFC1918 default-action permit-any
!
interface gigabitethernet2
 switchport trunk allowed vlan add 60
!
interface gigabitethernet3
 switchport trunk allowed vlan add 60
!
interface gigabitethernet10
 switchport trunk allowed vlan add 60
!
interface gigabitethernet11
 switchport trunk allowed vlan add 60
!
interface gigabitethernet13
 switchport mode access
 switchport access vlan 200
!
interface gigabitethernet14
 switchport mode access
!
interface gigabitethernet15
 switchport mode access
!
interface gigabitethernet16
 switchport trunk allowed vlan add 90,95,200
!
interface gigabitethernet23
 switchport mode access
 switchport access vlan 200
!
interface gigabitethernet24
 switchport mode access
 switchport access vlan 1
!
exit
ip default-gateway 172.16.1.1


some oneNetwork Architect
CERTIFIED EXPERT
Top Expert 2014

Commented:
Your switch is in router mode so 4094 is mapped to an internal routed port.

Just pick another VLAN ID that you don't use anywhere else. It's just the native VLAN ID which you need to set on the trunk. This is normal. 4093 will work fine.

Author

Commented:
I'm following this guide, and I must put native vlan 4094 of trunk
https://blog.scottlowe.org/2006/12/04/esx-server-nic-teaming-and-vlan-trunking/
Hello ThereSystem Administrator
CERTIFIED EXPERT
Distinguished Expert 2018
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Network Architect
CERTIFIED EXPERT
Top Expert 2014
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.