We help IT Professionals succeed at work.
Get Started
Troubleshooting Question

ESXi 7.0, Windows 2012 R2, VMware Tools problems

35 Views
Last Modified: 2020-11-13
One of my Windows 2012 VMs is having problems with the VMware Tools. Some observations:
  • On the vCenter client, when I right-click the VM and click Power, the Shut Down Guest OS and Restart Guest OS options are disabled. The VM is up and running.
  • When I select the VM and click Summary, I see VMware Tools: Not running, version:0 (Unsupported older version). On the Windows Server, when I click the VM Tools icon on the taskbar, the about panel shows Version 11.1.1, build-16303738 (the same as my other VMs which are current and work). The VM Tools icon on the taskbar has a yellow exclamation mark (!) and the mouseover text says VMware tools can be updated.
  • When I click to update the tools, I bring up the VMWare CD and run Setup64.exe, I get the options Modify, Repair, or Remove. Modify doesn't seem to do anything, repair seems to work correctly but doesnt fix the problem, and Remove works (it removes the tools), but when I install the tools, same problem.
  • The VMware Tools Service is running. In the Event Viewer, the only events for VMTools are informational, service starting and stopping messages. I tried turning on logging as debug, and looked at the logs but I didn't see anything that looked like an error. I am not good at reading VM logs though. 
  • The VM's network device is an E1000E adapter. I tried the VMXNET3 adapter, same problem and other, bigger problems. Some of the other 2012 VMs have the VMXNET3 adapter, others have the E1000E. Only this one VM has tools problems. The problem is the VM seems to not recognize the VMXNET3 adapter if the tools are not installed. It creates an Unknown controller and device in the Devices panel (view hidden) and the VM has no networking capability. If the tools are installed, I can get the adaptor to at least install (I still have to delete some unknown devices), but I have the same problem and a few more (the tools service seems to stop for no reason, and other issues.
  • I completely deleted and then created a new VM (except the hard disks). Same problem.
  • I uninstalled the tools and then reinstalled them, typical install and full install. Same problem.
  • We are at vCenter 7.0.1 build 17005016, ESXi, 7.0.1, 16850804 (the latest), and Windows Server 2012 R2 with the all of the latest updates applied. The hardware is a new Dell PowerEdge T140 with a Xeon 2276 processor, latest  firmware applied.
I dont know what else to try. Any suggestions would be helpful.
Comment
Watch Question
VMware and Virtualization Consultant
CERTIFIED EXPERT
Fellow
Expert of the Year 2017
Commented:
This problem has been solved!
Unlock 1 Answer and 11 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant

An Experts Exchange subscription includes unlimited access to online courses.

Get Started
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE