Link to home
Create AccountLog in
Avatar of Ben Conner
Ben ConnerFlag for United States of America

asked on

VCSA Update fails in precheck and goes into continuous loop

Hi,

Tried updating the vsn 7 VCSA with the current update and after passing the initial prechecks, launched the update.  What came back after running through the installation prechecks is the window below.  Clicking on Close just recycles the same update/error message.  Logging back in puts me back in the same place as well.

Any suggestions!

User generated image
Avatar of RAFA
RAFA
Flag of Venezuela, Bolivarian Republic of image

Hello,

Check the following link, it refers to the error you are presenting.

https://www.virtuallyghetto.com/2021/03/vcsa-7-0-update-2-upgrade-issue-exception-occurred-in-install-precheck-phase.html

Regards.
Avatar of Ben Conner

ASKER

Thanks, Rafa.  That partially worked: deleting the .conf file at least got it out of the loop.  But running the command:

software-packages install –url –acceptEulas

in the shell window resulted in the error message:

bash: software-packages: command not found

Logging through the VAMI and trying again resulted in the same loop occurring.

hello, i understand,

please check this link.

https://www.vgarethlewis.com/2020/11/05/vmware-vcenter-server-update-failed-exception-occurred-in-install-precheck-phase/
Hi Rafa,
Sorry for the delay.  The link suggested I d/l the update and create an iso and use that.  Unfortunately this is a VMUG Advantage license and I couldn't find a way to d/l the update separately.  ?

--Ben
Hello,

I understand that you are installing VCSA version 7, but I want to validate the Build. If you can facilitate it please.
Of course.  Current build is:
Product:VMware vCenter Server
Version:7.0.1.00300
Build number 17491101

Would it be easier to try a new test vCenter Server and see if that upgrades?  Then assign the hosts to it?
ASKER CERTIFIED SOLUTION
Avatar of RAFA
RAFA
Flag of Venezuela, Bolivarian Republic of image

Link to home
membership
Create a free account to see this answer
Signing up is free and takes 30 seconds. No credit card required.
See answer
Thanks.   Will try to get to that this evening.
Ok very good, I am pending.

Greetings.
Lots of folks on the VMUG list started asking about updates.  They just uploaded all of them last night.  Am downloading the VCSA update ISO now and will give that a shot. I'm assuming this is the correct one?

VMware-VCSA-all-7.0.2-17694817.iso
Hello,

Try that new iso, and tell us if the update was successful
Will do
Well, unfortunately it didn't find any updates to apply from the iso file.  I copied the a repo dist zip file and unzipped it to one of my local sites with a secure cert and tried that.  May not have gotten the URL precisely the way the VCSA update code is looking for.  Will take another look at the article.
I cloned the VCSA so I could do testing more conveniently in isolation w/o affecting anything else.

Tried pointing the CD drive to:
VMware-VCSA-all-7.0.2-17694817.iso   and then to
VMware-VMvisor-Installer-7.0U2-17630552.x86_64.iso
Neither responded with any updates.

I also have the folders in VMware-vCenter-Server-Appliance-7.0.2.00000-17694817-updaterepo.zip parked on one of my local sites that have a secure cert, in a folder called vc_update_repo.  I see a couple of sub-folders in that folder called manifest and package-pool.

Were I to update the url for the update function to inspect, what would I put as the site url, say if I called the repo folder vc_update_repo?

Thanks!

--Ben

Hello, I hope you are well.

Please enter your VCSA console, https://ip_fqdn_vcsa:5480 https://ip_fqdn_vcsa:5480 

Select the Update option and please give me a screenshot of what it tells you. Please click on Check Update to validate which version you want to upgrade to. But first you pass me the catch.

Width a reference image.


User generated image
Current info:
User generated image
And URL I'm using:
User generated image
Hello,

When you click on check update, does it show you the error on the screen? If so, restart the vcsa, re-enter the administration console through port 5480 and click again on check update
If after the reboot, it does not find any update and continues with the same error.

Investigating a bit more about what is happening, the state.conf file should be updated.

I leave you this reference link, the link is in Spanish but take it to English, however it has images that help guide you.

https://aprendiendoavirtualizar.com/error-vcsa-7-exception-occurred-in-install-precheck-phase/

This is another link, in English, but it is very generalized, I think the line above will help you more.

https://rnelson0.com/2020/10/30/vcenter-7-upgrade-fails-with-exception-occurred-in-install-precheck-phase/

You tell me the results,

Stay tuned.
During the checking on updates, a 2nd update came in from VMWare and I had 2 to pick from.  But couldn't select the most recent one to try.

Decided to pull the plug on this VCSA and I created a new one, migrated the hosts to it, and went through the hassle of redefining all my Veeam jobs since the security keys no longer matched.  

Things seem to be back to normal.  

Did learn several good things to do during this process which I really appreciate.  Hopefully this won't happen again in the near future.

--Ben
Hello,

What good news.

Sure, you always learn new things in this area of technology.

I hope my help has helped you during this process.

Regards.
Sometimes, if it is an option, the best one is to walk away and start over..

--Ben