Link to home
Start Free TrialLog in
Avatar of JoeM21
JoeM21Flag for United States of America

asked on

HP OfficeJet Pro 8740 Scan to email - won't authenticate on outgoing account.

Scan to Email had been working with a CompuServe "from" account. CompuServe required me to change to an application password. I couldn't get it to pass the Scan to Email setup test. I got "Incorrect credentials". After a number of tries, I switched the "Outgoing Email Settings" to what I was using for Email Alerts. Same account, server, port, options. Email alerts work. Scan to Email setup test fails with the same setup information. It still gives "Incorrect credentials". What's going wrong?
 
------
FW:  EBPDLPP1N001.2107A.00 build 2021-02-08
Printer wired on LAN.
Avatar of Robert
Robert
Flag of United States of America image

I have run into similar issues with other HP devices and usually I end up changing firmware versions to correct the problem. That said it appears you are already on at least a current version (based on the date in you post). You could try downgrading it to a previous version, unless the version your using has fixes in that you need. I would start there and see if that solves the authentication problem. 
Avatar of JoeM21

ASKER

Thanks for the advice. Looks quite reasonable.

I ran into a problem trying to downgrade - I can't find a previous version of the firmware! Page https://support.hp.com/us-en/drivers/selfservice/hp-officejet-pro-8740-all-in-one-printer-series/7902055 only leads to the current firmware version. I can't find anything like "previous versions" or "version history". Am I blind or am I collateral damage in HP's war against non-OEM ink (note that I have HP cartridges)?

Any suggestions?
ASKER CERTIFIED SOLUTION
Avatar of Adam Leinss
Adam Leinss
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of JoeM21

ASKER

I tried SMTP2Go and got the same results. I have very little visibility into what is happening. My guess is that the problem is in the HP8740 or I screwed something up in the SMTP2Go setup. I don't have a lot of faith about the HP message "Incorrect credentials. Check your username/password and try again." means that only the user name or password was wrong.

Thanks

Unsure if you’ve tried examining your email account security settings. Maybe it’s something with app passwords or account security settings. Do you use 2FA? Or did you generate an app password? I would experiment there.

I would also would recommend reaching out to HP as a last resort as well.

i found this :    Solved: Scan to email shows incorrect credentials - HP Support Community - 6643633 
.Under the Account settings ,there would be an option saying "Allow less secure Apps ",so check it and scroll the bar to turn it ON
Getting the old version of the firmware can be a problem as HP usually takes down the previous versions fairly quick.
If you don't have a copy of the previous firmware saved somewhere the only way to get the previous version would be to contact HP support and ask them for it. usually you start with a ticket with their support (if the printer is still under support agreement) when they are unable to fix the issue they will usually give you a copy of the previous version. Obviously this is not an option unless you have a support agreement or are willing to pay for their support. That said you can sometimes find sites that will host previous versions of their firmware (but you need to be careful to find a trustworthy site). 
Avatar of JoeM21

ASKER

Sorry for the break. I was thrashing. I have done more testing and am still getting confusing results.

I now have three outgoing servers to choose from: smtp.compuserve.com (port 465), smtpout.secureserver.net (port 465), and mail.smtp2go.com (port 2525).

I set up "Outgoing Email Profiles" for each. They all work. I then set the "Outgoing Email Settings" for each in turn using the same configurations that I have used in the profiles. smtp2go works. compuserve and secureserver fail. I believe that my earlier fail with smtp2go was a typo on my part because I can think of no other reason why it started to work. I have retried compuserve and secureserver multiple times to rule out typos. No luck. I cannot think of why the same credentials would work in an "Outgoing Email Profile", but not in the "Outgoing Email Settings".

I still don't know why this stopped working, but at least I have some functioning thanks to Adam Leinss' suggestion of smtp2go. If I don't get a solution in the next couple of days, I will call it and give Adam credit.


Maybe your ISP is blocking port 465 outgoing for SMTP?  You could try this: https://rcmtech.wordpress.com/2016/08/02/send-email-via-yahoo-with-powershell/ and see if you can send over port 465 using the two that don't work.  If they don't work with the Powershell code, you could try loading a VPN client and then re-test.  Windscribe has a free VPN good for 10GB/month: https://windscribe.com/features/use-for-free.
Avatar of JoeM21

ASKER

Thanks Adam, but I am pretty sure that it is not my ISP.

Two of the working "Outgoing Email Profiles" are using port 465 to successfully reach smtpout.secureserver.net and smtp.aol.com (smtp.compuserve.com in previous post was a typo). So port 465 works when used in the sender profiles, but not when used in the "Outgoing Email Settings" for Scan to Email. In case you are not familiar with the HP8740 profile mechanism, it allows printer users Tom, Dick, and Harriet to each have a separate sending email address and outgoing server.

Also, the basic email alerts ("paper out", etc.) have been set to use smtpout.secureserver.net over port 465 and continue to work.

I will test using port 587 tonight since the failing configurations are both using 465. Port 465 has never been official and maybe HP is changing its firmware to tighten up security (in piecemeal and unannounced).





Avatar of JoeM21

ASKER

I can use Compuserve and SecureServer email servers for Scan to Email. I plan to use SMTP2Go as suggested by Adam (thanks)

I believe that HP made firmware changes in April that broke the normal Scan to Email over port 465, but did not break it when using it with email profiles or the email alerts. I had been using port 465 for SecureServer for years. It stopped working in late April. I did not know what the problem was and decided to switch to Compuserve while I was at it. I had problems which were wrongfully (I believe) attributed to application passwords. This would have been easy to verify by reverting to the previous firmware, but HP has hidden earlier versions.

Here is the result of my testing that points the finger toward some printer changes relating to the use of port 465:

                Settings     --- Scan to Email ---
                                 Outgoing   Outgoing
                  Email        Email       Email
                  Alerts        Setting     Profiles

Compuserve (smtp.aol.com)
   port 465     ---           Fails       Works
   port 587     ---           Works     Works

SecureServer (smtpout.secureserver.net)
  port 465     Works      Fails       Works
  port 587      ----          Works     Works

SMTP2Go (smtp.smtp2go.com)
  port 465       ----           ----          ----
  port 587       ----           ----          ----
  port 2525     ----         Works      Works